Your frequently asked questions – and our solutions

Our technical support team has been asked lots of questions by Allplan users over the years and our solutions have been stored in a knowledge database.

As a Serviceplus customer, you can search the full database for the answers you need.

Search

Support Filter

Result

Recommended Knowledge Article(s)
112 results:

Fixing NemSLock after Windows update

Version:  Allplan 2013, Allplan 2014, Allplan 2015  | Last modified: 27.02.2024 14:59
 
rate

Question:

After I updated Windows (8 to 8.1; 8.1 to 10), Allplan only starts as a viewer. What can I do?


Answer:

Windows update corrupts Nemetschek Softlock License Manager.
To fix Allplan, do the following:

You need the latest installation package for your version.
You can download this package from our webdrive

https://webdrive.allplan.com/s/4LrjrymoxESzC6p

You can find the installation packages in the following path:
Allplan/"Version"/Installationspaket/

Copy the zip file to the local computer and unzip the file.
Start the installation and run an update use our temporary license file.

You can download the temporary license from Allplan Connect:
https://connect.allplan.com


After the installation, you can open License Manager again (Services application -> Utilities -> License -> License Manager). Next, install the temporary license (*_psd.nslock): "Install - Install license"
Note: the status of the temporary license is set to "Expired".

Next, create a new registration request.
To generate a registration request, do the following:

Open License Manager (Services application -> Utilities -> License -> License Manager). Select the license entry for your seat and click "Request license".
Follow the instructions displayed on screen. Complete the form. Do not forget to enter your email address.

Check that the Client ID and CD Key are correct.

Send the registration request to: register@nemetschek.de.

Controlling license selection

Version:  Allplan 2024, Allplan 2019, Allplan 2017, Allplan 2018, Allplan 2022, Allplan 2020, Allplan 2021, Allplan 2023, Allplan 2016  | Last modified: 27.02.2024 12:08
 
rate

Question:

I have several licenses, but I want to use a specific license to start Allplan. How can I do this?



Answer:

Open the license settings on the client:

Services application -> Utilities -> License settings -> License selection

You can see all the licenses that are available on the network. You can control license selection as follows:


Select the check box in front of a license to select this license as a favourite. You can mark as many licenses as you want. Allplan will then prefer these licenses. Click to select one or more licenses Allplan is not to use.

Make settings as you need.

If you do not select any license or if you have selected several favourites, Allplan will automatically use the first free license it finds.


Note:

Check which licenses are available.
Available column:
This column shows how many licenses are still available. For example, 3/5 indicates that 3 out of 5 licenses are still available. Click the dropdown arrow to see a list of users currently working with a license.

Allplan 2021 - System requirements

Version:  Allplan 2021  | Last modified: 28.02.2024 08:35
 
rate

Question:

Where can I find the system requirements and the system test for Allplan 2021



Answer:

Under the following link you will find comprehensive information on the topics:

- system test
- System requirements
- Graphic cards


www.allplan.com/info/sys2021




Note:

The following link contains computer models tested and recommended by Allplan:

https://connect.allplan.com/support/certified-hardware.html

cinerender is not executed

Version:  Allplan  | Last modified: 27.02.2024 13:41
 
rate

Frage:

Warum kann der Cinerender nicht gestartet werden?



Antwort:

Prüfen Sie bitte, ob auf Ihrem Computer das Programm "ManyCamService.exe" installiert ist. Deaktivieren Sie dieses Programm gegebenenfalls.



Hinweis:

in der Firewall wurde der Cinerenderer für eingehende sowie ausgehende Regeln bereits "whitelisted" .

Mögliche Ursache für das Phänomen:
Das Programm "ManyCamService.exe" reagiert auf den Port 1234, welchen Allplan bei Starten des Cinerenderers adressiert und behindert so die Kommunikation zwischen Allplan und Cinerenderer.

Der Port 1234 ist der für VLC media player (VideoLanClient) standardisierte Port. Über diesen Port kommuniziert sowohl der Cinerenderer als auch das beim Kunden installierte Programm ManyCamService.exe




 

FIXTURE - Manufacturer catalogue data

Version:  Allplan Precast  | Last modified: 28.02.2024 08:03
 
rate

Question:

How can manufacturer catalogue data be installed or updated retrospectively?



Answer:

To install or update manufacturer catalogue data, such as the reinforcement connections from ERICO-Lenton, at a later date, please proceed as follows:

Firstly, you need the latest installation package for your version
You can find this either on Allplan Connect (www.connect.allplan.com), or from our webdrive at

https://webdrive.allplan.com/s/4LrjrymoxESzC6p

The installation packages can be found under
Allplan/"Version"/Installation package

(Click on the three dots to the right of the file size and select Download)

Note: Do not download all files (that's about 450GB!), but only the installation package for the version you need.

Copy the zip file to your local computer.


1. please open your STD directory of the central file storage via the Allmenu of the Allplan version to be updated.




2. please close all running Allplan applications and the Allmenu in the company again

3. rename the Prod subdirectory in the STD directory you have just opened to Prod_old

4. now unpack the ZIP file of the version you have just downloaded in an empty directory and then start AllplanSetup.exe by double-clicking the left mouse button




5. please select "Update" when asked for the installation option



6. when asked for the licence to be used, simply select "Use active licence"
7. under "Setup type", now select the Customised variant​​​​​​​



8. you can then first decide again on the languages to be installed

9. in the following window, you can select the manufacturers from which you would like to install the current catalogue data for the products. Please make your selection here.​​​​​​​



10. then you will be asked for the country packages, which is usually easy to confirm.

11) Finally, you will see a small overview window in which you can start the update installation.

After successful installation, the current catalogue data should now be available when using the functions for the reinforcement connections and can be used without any further messages.​​​​​​​


Hint:
Ideally, have these instructions carried out by your IT service provider/administrator.

Workgroup Manager: Problems when checking in or out computers

Version:  Allplan 2020, Allplan 2022, Allplan 2021, Allplan 2023, Allplan 2019, Allplan 2024  | Last modified: 27.02.2024 14:03
 
rate

Question:

I can neither check in nor check out the computer.
When I try to check in the computer, the following error message appears: “The registry entries are not correct!” How can I correct this error?


Answer:

There is a hidden file on the server. This file causes the problem, which is probably related to user rights or user account control.

You have to change the settings directly on the server, that is so say, you have to use the folder options to show all hidden folders and files.

1. Open the central file storage folder on the server. There is a subordinate folder called
NET. This folder contains the computer_name.out file. Here, computer_name is the name of the computer that is checked out.
Delete this file.

2. Open the shared folder (for example, C:\Nemdata\Allplan) on the computer that is checked out.
Allplan 2015 and earlier: Delete the Net.ChkOutfolder.
Allplan 2016 and later: Delete the NETfolder.

Now the computer is checked in again. Consequently, you can move projects to this computer
or check it out once more.


Note:

If the computer or the projects are still red, you have to fix the projects.

To fix the projects:
Services application -> Workgroup Manager -> Administer projects and computers

Do the following:

Ctrl + right-click computer
-> can be checked in
Ctrl + right-click project-> can be unlocked

Repeat this step to unlock every project on the computer.
When you have finished, close the dialog box and open it again to update it.
Now everything should be correct.

Updating license server and licenses

Version:  Allplan 2022, Allplan 2020, Allplan 2017, Allplan 2016, Allplan 2021, Allplan 2018, Allplan 2023, Allplan 2019, Allplan 2024  | Last modified: 27.02.2024 10:48
 
rate

Question:

How to update the license server and the licenses?



Answer:

Allplan 2016: Before you do anything, make sure Allplan 2016-1-4 or later is running on all clients.
Allplan 2017 and higher: Check the version of the license server as described below and update the licenses.

1. Updating the license server
Check the version of your installed license server on the server. Starting with the license server version 2016-1-4, the detailed version status (Build-ID) is displayed directly in the lower left corner of the License Settings program.
The latest version 1.11xx.xxx.xxx should be displayed here. If an older Build ID is displayed, then you still have an older license server in use. In any case, please update your license server. Download the software for the license server from Allplan Connect - license server version 2021 or from the following link.

https://webdrive.allplan.com/index.php/s/4LrjrymoxESzC6p

The package is in the folder

/Allplan/Lizenzserver/2021/

Start the new License Server Setup on the server or computer you use as the license server. Right-click the *.exe file and select 'Run as administrator' on the shortcut menu.

  • Click Install.
  • Click Exit.

If you have not yet installed the license server or if you have not switched to Allplan 2016 or higer until now, you can find detailed step-by-step instructions at
https://connect.allplan.com/en/faqid/20150618084450.html


2. Updating the licenses
Update the licenses at the license server as follows:

  • Start the License Settingsprogram on the server.
  • Click License activationon the left. Then click the license you want to update so that this license is highlighted in blue.
  • As you can see, the 'Update license' function is now available.
  • Click Update license.
  • If your license includes configurations for several seats, you must update each license separately.

Note: When updating the license it can be that you will receive a higher version of the license as the version of Allplan you are using. The license is downward comatible and can be used until Allplan 2016.

Transferring projects with all settings to partner offices in Allplan 2018-1 or later

Version:  Allplan 2019, Allplan 2021, Allplan 2020, Allplan 2018  | Last modified: 27.02.2024 14:42
 
rate

Task:

You want to transfer a project with all its settings to a partner office for further editing.

Note:

The following description works only if both partners use the same version of Allplan (Allplan 2018-1 or later).

1. Backing up the project:

Before you back up the project, make sure that “office” or “project” is selected for the path settings of the project.
To do this, open ProjectPilot and select the project: right mouse button -> Properties-> Settings. Here, you can select the path settings.
For exchanging projects with partner offices, we recommend that you switch all project settings to “project”.
This ensures that all pen definitions and line definitions, user-defined fonts, patterns and hatching styles, bar and mesh cross-section catalogs, and layer definitions will be copied to the project and backed up together with the project.

Note:
After the backup, switch the path settings back to “office”. But do not change the paths that already had the “project” setting.

Start Allplan and select the “File” menu -> “New Project, Open Project...”.
Right-click the project that you want to back up and select "Create project backup".
(Allplan 2018: Select “Compress and export project”: )
Select the folder where you want to save the project.

2. Importing the project:

To add a compressed project to the "New Project, Open Project" dialog box

Start Allplan and select the “File” menu -> “New Project, Open Project...”.

  • Drag a compressed project (*.zip) from the desktop or from File Explorer into the "New Project, Open Project" dialog box.
  • Specify the folder and enter a name for the project; then, click OK.
  • Allplan unzips the project, adding it to the project list.


Import: handling large coordinates, four options

Version:  Allplan 2017, Allplan 2021, Allplan 2020, Allplan 2019, Allplan 2018  | Last modified: 27.02.2024 13:56
 
rate

Question:

How can I import DXF and DWG files that contain elements with large coordinates?



Answer:

Imported DXF and DWG files that contain elements with large coordinates can cause performance problems in Allplan. To avoid problems with this data, you have the following options:

Option 1: set an offset
Set an offset in the project. In Allplan 2011 and later, you can do this directly when you create a new project. For existing projects, you can specify offset coordinates later. To do this, select the File menu -> clickOpen Project-> select the relevant project -> open the shortcut menu and click Properties. (In Allplan 2009 and earlier, select the Tools menu -> Options -> Advanced Draft -> Settings tab). The offset can also be set automatically during the import, which is described in option 2.

Option 2: adjust center of gravity to: offset
When importing, select the Options -> General Settings tab (Advanced Transfer Settings tab in V2008 and earlier) and select the Adjust center of gravity to "Offset" check box. The system automatically sets an offset in the project. Consequently, the origin of the file (= center of the min-max-box) is set to the origin of the coordinate system. This option is not available if you have already specified an offset or if the data to be imported does not contain large coordinates.

Option 3: adjust center of gravity to: origin
When importing, select the Options -> General Settings tab (Advanced Transfer Settings tab in V2008 and earlier) and select the Adjust center of gravity to "Origin" check box.This moves the center of the file to the origin of Allplan’s coordinate system. As opposed to the previous option, the coordinates themselves are changed. Use this option only when you do not need to export the data again.

Option 4: adjust center of gravity to: off
This imports the data into Allplan; the coordinates are not taken into account. To optimize working with large coordinates, select the Options -> Desktop environment page -> Optimize working with large coordinates (in Allplan 2009 and earlier: Tools menu -> Options -> Global Options -> 'Miscellaneous' tab -> Optimize working with large coordinates). However, the larger the volume of data you create far from the origin, the slower the performance might get. In addition, you can can move the data to the origin using Allplan's "Move" tool and, if necessary, specify a corresponding offset later.



Note:

Using an offset (as described in the first two options) is usually the better solution. You edit the data at the origin of the coordinate system but - due to the offset specified - point coordinates are measured correctly. The offset set is automatically taken into account when you export and import data, and it applies to the entire project.
If you do not need to export the data with the same coordinates again, we recommend that you use option 3 - adjust center of gravity to: origin.

License activation /returning is still not possible

Version:  Allplan 2023, Allplan 2021, Allplan 2016, Allplan 2017, Allplan 2022, Allplan 2020, Allplan 2018, Allplan 2019, Allplan 2024  | Last modified: 28.02.2024 07:42
 
rate

Question:

Internet connection exists on your computer and the settings used for the proxy for the URLs you have set also. You try to activate your license with your product key, but the activation could not be performed. You get the message ' server not found error'. How can the license be activated yet?

Reply:

License activation:

The following description is valid for single user license as also license server licenses.

Try to activate the licenses on the computer/server via the following website online.
This Web site must be launched directly on the computer on which the license should be enabled.


http://lc.codemeter.com/59885/depot/index.php

In the row "Ticket", enter your Product Key and click continue your license will be displayed, click on activate license now.

Note: (only for license server license)
A selection appears asking for the binding of licenses.
Select firm code 6000100 on the right hand side.
'I want my licenses on one computer (CmActLicense). Firm code: 6000100 CmContainer ALLPLAN CM6 (2000)'

Sometimes multiple rows for the same license will be displayed (E.g. license number and a -u behind it) please leave all licenses checked and click on Activate selected licenses now.

The transfer of the license starts now. When activation is finished your license on this page should now appear with status activated.

If the problems with license activation occurred during the installation of ALLPLAN, cancel to exit Setup and restart the installation of ALLPLAN again. Then select in the Setup license configuration use active license now and the installation can continue.

Then open the license setting over services -> utilities-> license settings.
Or license server via License Settings.

Click on the left side on license selection. Now the license is displayed under the computer name.

License return:

This Web site must be launched directly on the computer on which the license should be enabled.


http://lc.codemeter.com/59885/depot/index.php

In the row "Ticket", enter your Product Key and click continue your license will be displayed, click on re-host license now.

Sometimes multiple rows for the same license will be displayed (E.g. license number and a -u behind it) please leave all licenses checked and click on Re-host selected licenses now.

The transfer of the license starts now.

Notes:

  • Sometimes the license is not displayed under license activation, because it has been enabled via the website.
  • If you want to remove the licenses, you must do so via the website again.

Operate Allplan with a QHD/UHD/4K monitor from Allplan 2023

Version:  Allplan 2023, Allplan 2024  | Last modified: 27.02.2024 13:42
 
rate


Question:

The icons and descriptions in Allplan are too small, too big, or blurry, how can you change that? How can Allplan be operated with a QHD/UHD/4K resolution?



Answer:

From Allplan 2023, the setting will be adopted from the Windows display setting so that Allplan adapts correctly to the high-resolution screens.
For this to work properly, it is crucial that the QHD/UHD/4K screen is defined as the main screen.

Background: Allplan always starts automatically on the defined main screen, so it is important that this is correctly defined and scaled so that the display in Allplan is correct.
 

Check/set the following settings:



1. To ensure that changes to the settings are applied correctly, first close Allplan

2. Go to Windows Settings. Start -> Settings -> System and select Screen. Or right-click on the desktop and select Display Settings.

Windows 10: Click Identify, then click your QHD/UHD/4K screen in the display so that it turns blue.
In the area below under the Multiple Screens section, select 'Expand this display' and apply the setting. Then check the box for 'Use this display as main display'.


Windows 11: At the top under the screen display, select 'Expand this display' and apply the setting. Click Identify, then click your QHD/UHD/4K screen in the display so that it turns blue. As the first entry under Multiple screens, tick 'Use this display as main display'.

Here is an example for Windows 11

20-03-_2023_13-53-40.png

 

Leave the scaling and resolution at the recommended values.

3. Start Allplan and test the view. You may need to increase the scaling a little, depending on how big you want the icons etc. to be. To do this, exit Allplan again and increase the scaling, for example to 125% or 150%, and then start Allplan again.

 
Hints:
- If Allplan is dragged from the QHD/UHD/4K screen to the smaller or non-high-resolution screen, the icons in Allplan are all larger.
- if the smaller, non-high-resolution screen is the main screen, then everything in Allplan is displayed too small.
- If the display in Allplan is blurry, then it is probably because the screen was not expanded but was duplicated. Then the resolution of the smaller, non-high-resolution screen applies and the display in Allplan is blurry. QHD/UHD/4K cannot then work because the settings are adopted from the smaller, non-high-resolution screen and only transferred to the larger screen.

 

Using bak files

Version:  Allplan 2021, Allplan 2017, Allplan 2019, Allplan 2020, Allplan 2016, Allplan 2018  | Last modified: 27.02.2024 14:19
 
rate

Question:

Does Allplan create backup files (*.bak)?
How can I use these files?



Answer:

Allplan creates backup files when you do the following:

  1. Copy, Move Elements between Documents …
    Allplan creates a backup file of the destination drawing file or layout.
  2. Deleting drawing files and layoutsin the "Open on a project-specific basis" dialog box
    If you have selected "Create backup copies of drawing files", Allplan creates a backup file of the drawing file or layout.
  3. Importing data to drawing files
    If you have selected "Create backup copies of drawing files", Allplan creates a backup file of the drawing file.


Note on points 2 and 3:

To select the "Create backup copies of drawing files" option, click
Tools -> Options -> Desktop environment -> Save/load area (until V2009 Global Options -> Miscellaneous -> Autosave, Backup)->Create backup copies of drawing files.


Restoring:

If need be, you can restore the original drawing file or layout.
Make a note of the drawing file number or layout number and determine the corresponding project folder as follows:
Services application -> Service -> Hotline Tools -> wopro

Open this folder in Windows Explorer.

Rename the corresponding drawing file "tb000001.ndw" "tb000001.ndw.old" or the corresponding layout "pb000001.000" "pb000001.000.old.", for example.
Delete the bak extension from the corresponding bak file.

Example 1:

You have inadvertently copied the wrong elements to drawing file 4711.
1st step: exit the project in Allplan.
2nd step: delete file tb004711.ndw or rename it tb004711.ndw.old.
3rd step: find file tb004711.ndw.bak and rename it tb004711.ndw.

Example 2:

You have inadvertently copied the wrong elements to layout 815.
1st step: exit the project in Allplan.
2nd step: delete file pb000815.000 or rename it pb000815.000.old.
3rd step: find file pb000815.000.bak and rename it pb000815.000.



Note:

These backup files can considerably increase the volume of data to be backed up. So it is a good idea to delete the .bak files you no longer require before you start backing up data. To delete the .bak files, you can select the Services application and click Utilities -> Delete temporary files.

You can also find this information in the help for Allplan. Please refer to the topic "Using bak files".

Switching from single installation to network installation without Workgroup Manager

Version:  Allplan 2013, Allplan 2014, Allplan 2016, Allplan 2020, Allplan 2019, Allplan 2018, Allplan 2021, Allplan 2017, Allplan 2015, Allplan 2012  | Last modified: 27.02.2024 14:12
 
rate

Task:

You have installed Allplan on several local workstations. Now you want to change the installation so that you can access a common network drive.



Note:

Before you switch to a network installation, it is essential that you back up all the data of all the workstations.
We strongly recommend that you take advantage of the expertise of Nemetschek’s technical support staff. We are happy to help you!



Solution:

The following description shows how to change several workstations where Allplan is installed locally and the project data is also stored locally on each computer to workstations with a common network drive without Workgroup Manager.

1st - getting ready
Choose one of the workstations where you will install all the projects and the office standard (hereinafter referred to as the main workstation).
First, move all the projects to the main workstation.

1.a: copying resources into projects
To make sure that the projects in your office have a uniform appearance, change the path settings for the projects' resources to 'Project'.
Make the following setting for each project:
Allplan -> File menu -> ProjectPilot - Admin -> select the individual projects one after the other -> right mouse button -> Properties -> Settings tab
Set the path settings for 'Pen and line definitions', 'Fonts', 'Patterns, hatching styles, area styles', 'Bar and mesh cross-section catalogs', 'Layer structures, line styles, drawing types' and 'Attributes proposed' from 'Office' to 'Project', if necessary.
The corresponding elements are copied from the office standard directly to the project. This ensures that the project settings stay the same even when you copy the project to the new server with the new office standard.

1.b: same folder name as project name
Open the 'General' tab and select the 'Same folder name as project name' setting if you want to proceed as described in 2b.

1.c: pen color ("Color stands for pen")
The pen color for the "Color stands for pen" setting is a user-specific setting that is not saved in the project but in the user folder (...\Usr).

2.a: backing up projects of the individual workstations and importing them to the main workstation (recommended method):
Back up the individual projects. To do this, open the Services application and select Data Backup -> Create -> Entire folders -> Projects.
You can back up several projects in a single operation.
Before you start, specify the backup folder on the network or on the local hard disk: Services application -> Configuration -> Backup path ->Browse for Folder.

The next step is to import the saved projects to the main workstation.To do this, open theServices application -> Data Backup -> Import -> Projects Before you import the individual projects, you can create new Allplan projects at the main computer. As an alternative, you can also create a new project during the import.

2.b: backing up projects of the individual workstations and importing them to the main workstation (special approach):
This approach should only be used with good reason for exceptional cases as it requires in-depth knowledge of Windows.
With this method, Windows Explorer is used to import the projects to the main workstation.
If some project names exist twice, you need to rename these projects before you back them up.

You can then rename the existing 'project.dat' file in the Prj folder of the main workstation.
Next, select the Services application -> Service -> Hotline Tools -> reorg -> Restore project management file.
The system creates a new project administration file (project.dat), which should list all projects with names.

Now the main workstation contains the latest version of all the projects of the office.

3rd - merging project defaults
Open ProjectPilot at the individual workstations and copy the elements you want to transfer (symbols, smart symbols, lists, schedules, and so on) to the external path. Of course, you can set the external path to a common network folder that can be accessed by all workstations.
Next, open ProjectPilot at the main workstation and copy the contents of the external path to the office standard.

4th - data backup

  • Back up the projects, office standard and user settings at the main workstation:
    You can also copy the ..\prj (projects), ..\std (office standard) and ..\usr (user folder) paths to a backup folder (Nemsic, for example) on the hard disk.
  • In addition, you need to back up the ..\usr\local folder at every stand-alone computer.
  • Export the user interface setting of each user to a file: Allplan -> Tools - > Customize .... -> Export...


5th - uninstalling
Remove Allplan from all workstations.

6th - reinstalling
Before you install the same version again, create and share a folder (Nemdata, for example) on the future data server. Create a subfolder - Allplan - in this folder.

The next step is to reinstall the same version on all the workstations.

Specify the following installation paths:
Program folder:
local (C:\Programs\Nemetschek\Allplan, for example)
Central file storage folder:
Browse -> Network...
Find the sharedNemdata folder and select the Allplan folder.

After this, start installing.

7th - testing the start and restoring the backup
After the installation (check whether Allplan starts), copy the ..\prj and ..\std folders you backed up from the main workstation to the new ...\Nemdata\Allplan server folder.

Next, use Windows Explorer to copy the contents of the former user folder (…\usr\local) of the stand-alone workstation to the new user folder of the computer you just installed.

8th - updating the project administration file
Go to the project.datfile in the ...\Nemdata\Allplan\Prjfolder and rename itproject.alt.After this, do the following:
Services application -> Service -> Hotline Tools -> reorg -> Restore project management file.

9th - summary
Now all the workstations access a common network drive with the same project pool and office standard.
With this type of installation, only one user can access a project at any one time. If several users are to work on a project at the same time, you need to install Workgroup Manager.

Allplan silent installation (Allplan 2017 and later)

Version:  Allplan 2020, Allplan 2019, Allplan 2018, Allplan 2017, Allplan 2021  | Last modified: 28.02.2024 08:37
 
rate

Question:

Can I "automate" the installation of Allplan?


Answer:

You can install Allplan 2017 in silent mode. This installation mode is fully automatic; you do not need to enter anything. Silent installation is particularly useful if you want to install Allplan 2017 with the same settings on a large number of workstations on a network.

Requirements for installing in silent mode:

Pay attention to the different licensing types!

Licensing for stand-alone workstations:
Make sure you have not yet activated a license on the computer where you want to record silent installation. Use the Viewer option for recording.

After having installed all computers in silent mode, you must use the Product Key to activate the license locally on each computer.
To activate the license after installation:

  • Open the 'License settings' dialog box: Services application -> Utilities -> License settings
  • Click License activationon the left.
  • Enter your Product Key.
  • Click Activate license.


Using a license server:

  • The clients take the licenses from a license server.
  • The license server is installed.
  • The license of the license server is activated.

For more information on the license server, go to http://connect.allplan.com/de/support/loesungen.html?tx_nemsolution_pi1%5BdokID%5D=20161115093205.htmlhttps://connect.allplan.com/en/faqid/20150618084450.html
Use the Use active licenseoption for recording.

Setup writes the license settings to the %AppData%\Nemetschek\Lic3.ini file.You must distribute this file to all computers.


Some more tips:

  • Before you start installing, unzip the Allplan installation package (for example, using the 7_Zip program). Make sure this package is in a folder that can be accessed by all clients you want to install.
  • Start the command prompt for running the setup program always as a local administrator. To do this, open the shortcut menu and select "Run as administrator". Make sure you always start the command prompt from the correct folder.
  • Setup will automatically install any Microsoft components required by Allplan such as Microsoft .NET-Framework or Microsoft Report Viewer without prompting you to confirm.




Preparing to install in silent mode

To record and run silent installation, you need the installation files of Allplan 2017.
Installing in silent mode involves three steps:

Creating the log file for installing in silent mode

Start by installing Allplan 2017 with the /r option on a typical workstation. During installation, Setup automatically writes all entries to a log file named setup.iss. You can then use this file to install the program on the other workstations.

Installing in silent mode

Next, install Allplan 2017 with the /s option on all other workstations. Installation is based on the setup.iss log file you created in the first step.

Checking the installation

Finally, you should check the setup.log file, which was created automatically during setup, to see whether everything was installed correctly.

Note: When installing in silent mode, Setup usually uses the same setup.iss file to install the program on all workstations. However, you can edit some settings of the setup.iss file if you want to adjust paths. You can find more information in the help; see Adjusting the setup.iss filehttp://help.allplan.com/Allplan/2017-0/1031/Allplan/index.htm#331.htm


To install Allplan in silent mode, do the following:

Install .NET 4.6
Silent setup requires you to install .NET 4.6 in advance. The reason for this is that you have to reboot the computer after installation of .NET 4.6. This reboot would interrupt silent installation.


After you have downloaded the installation files, you must unzip these files before you can use them to install in silent mode.

  • Unzip the zip file downloaded. This results in an .exe file (for example, Allplan 2017-0-5-cad.exe).
  • Then unzip this .exe file using an appropriate program (for example, 7_Zip) and save the resulting file to any folder. You can now use the command prompt to start Setup.exe for recording.



1. Sample installation:
Start by creating a record file. To do this, run setup with the settings you need. You only need to do this once.

Use the command prompt to start this installation with the "/r" option (for record):

To run the setup program, open the command prompt as a local administrator and type the following:
setup.exe /r

Setup starts and runs as usual.

Stand-alone license:
When you are prompted to choose the license configuration, select the Use vieweroption.
License server:
When you are prompted to choose the license configuration, select the Use active licenseoption.


Setup logs the entire installation process, writing everything to the setup.iss file.

If you want, you can change the name and folder of this file:

setup.exe /r /f1<folder>:\Setup.iss
For example,
setup.exe /r /f1c:\Setup.iss
This saves the file directly to C:\.

Be careful:
There must not be any blanks between "f1" and the folder!

Copy the setup.iss file to a folder that can be accessed by all clients you want to install. It is a good idea to copy this file to the folder with the Allplan installation files.

License server:
Copy the %AppData%\Nemetschek\Lic3.inifile to the %AppData%\Nemetschek folder of every client.
If you install Allplan on a client for the first time, you must create the Nemetschek folder in %AppData% first (for example, C:\Users\Username\Appdata\Roaming\Nemetschek).


2. Silent installation:
Make sure you can access the setup.iss file.

License server:
Make sure the Lic3.ini file is in the %AppData%\Nemetschek\ folder.


Setup logs the entire installation process again, writing everything to the setup.log file. You can find this file in the same folder as the setup.iss file. With the /f2 option, you can specify a different folder and file name for the setup.log file.

To start installing Allplan in silent mode on a client, open command prompt as a local administrator and type the following:

setup.exe /s /f1<folder>:\Setup.iss /f2<folder>:\Setup.log

For example,
setup.exe /s /f1c:\Setup.iss /f2c:\Setup.log
This saves the file directly to C:\.

Check the setup.log file to see whether everything has been installed correctly. The [ResponseResult] section should return the 'ResultCode=0' value.



Note:

If you have several licenses or license servers, select the required license for each client using the Services application - Utilities - License settings.

Refer to the online help for detailed information on installing in silent mode.
http://help.allplan.com/Allplan/2017-0/1031/Allplan/index.htm#321.htm
To open the help system, press the F1 key during setup. Go to the "Contents" tab, select "Installing" and then "Installing in silent mode".

You can also find information in the help for the license settings:
Services application -> Utilities -> License settings
To open the help system, press the F1 key. Go to the "Contents" tab, select "Licensing Allplan using a license server" and then "Installing in silent mode".


Please note that we cannot provide support for this installation method.

License server - license borrowing / tracking which users have borrowed licenses

Version:  Allplan 2024, Allplan 2021, Allplan 2019, Allplan 2023, Allplan 2018, Allplan 2020, Allplan 2022, Allplan 2017  | Last modified: 27.02.2024 12:08
 
rate

Question:

You would like to know which colleague has borrowed a license from the license server and for what period of time it was borrowed?


Answer:

Prerequisite:
Please make sure that at least Codemeter version 6.60b is installed on the license server.
To do so, start the CodeMeter Control Center on the server
Either in the Windows Start menu via CodeMeter -> CodeMeter Control Center. Or enter Codemeter in the search bar of the start page and press ENTER. Under Help-> About you can see the installed Codemeter version. If a version lower than 6.60b appears here, install the latest version of the Control Center released by Allplan. Instructions on how to do this can be found at the following link https://connect.allplan.com/de/faqid/20160113131406.html


Application:
The administration of the license server is done via the CodeMeter WebAdmin application on the server itself.
Start the CodeMeter Control Center at the license server on the server
Either in the Windows Start menu via CodeMeter -> CodeMeter Control Center. Or in the search bar of the start page enter Codemeter
and press ENTER, then click WebAdmin in the dialog box at the bottom right.

Or:
Type Localhost:22350 in the address bar of your browser.

In WebAdmin go to Container -> All Containers -> here select your Allplan Cm6 in which your license/s have been stored -> select the desired license by clicking on the Product Code 999 in front of it. -> Now scroll down to the end, to the License Transfer History area.

Here you can see exactly when the license was borrowed, for how long and by which user.


Hints:
If you want to see which users are currently in the network pulling licenses from the license server, you can also see this. To do this, go to License Monitor-> Sessions in WebAdmin.

Borrowed licenses are currently only displayed with the container number under License Monitor-> Sessions, only under License Transfer History the user is also visible.

Since under License Transfer History it is a complete history, all license loans are listed, even those that have already been terminated, i.e. the license has been returned to the license server in the meantime.

Allplan silent installation from Allplan 2024-0

Version:  Allplan 2024  | Last modified: 07.05.2024 09:19
 
rate

Question:

How is a silent installation of Allplan from version 2024 carried out?

Answer:

Allplan has been installed using the Windows Installer since version 2022.
The Windows Installer has a number of advantages such as repairability and providing installation on a network. Allplan can also be installed unattended (“quiet”) using the Windows Installer.

Please note that no individual support can be provided for this procedure.
If you are unsure, ideally have your IT service provider or administrator carry out these instructions.


The following steps are necessary:

1. Edit the settings file
The settings file attached to this FAQ must be edited in advance in order to select the desired program components.
Here is a description of the structure of the settings.txt file:

· Installation options:
Set the desired installation option:

New installation:
No data is transferred from the most current previous version.
Value to be entered:
Upgrade=Upgrade.UpgradeNew
 
New installation with data copy:
Allplan is installed parallel to the previous version and the data (with the exception of the projects) is copied. Projects can be transferred to Allplan itself after the installation has been completed.
Value to be entered:
Upgrade=Upgrade.UpgradeKeep
 
Upgrade:
The latest available Allplan version will be converted into the current version.
Upgrade=Upgrade.Upgrade
 
· Paths:
Enter the desired program folder under "InstallPath" and the desired central file storage folder for Allplan under "CentralPath",
When storing data in a network, be sure to use the CentralPath in UNC notation.

Example:
InstallPath=C:\Program Files\Nemetschek\Allplan_2024
CentralPath=\\SERVER\CAD_Daten\Allplan\Allplan_2024

Important:
In the case of an upgrade, be sure to specify the path of the previous version for "CentralPath".


· Countries and languages:
Select the countries and languages to install from the list of suggestions in the file.
Set the main country with "DefaultCountry" and the main language of the installation with "DefaultLanguage".
Add additional countries and/or languages if desired.
Wichtig: For a functional installation, the main country and language must be specified.

Example:
# Country list: AUS AUT BEL BRA BUL CAN CHN DEU ENG FRA GRC HOL HRV ITA JPN KOR POL PRT RUM RUS SLK SPA SVN SWI TCH TRK UNG USA VNM YUG
# Language list: BUL CHN DEU ENG FRA GRC HOL HRV ITA JPN POL PRT RUM RUS SER SLK SPA SVN TCH TRK UNG VIE
DefaultCountry=DEU
DefaultLanguage=DEU
Country.ITA
Language.ITA
Language.ENG

· Advanced features:
Select the features or data you want to install from the list of suggestions in the file.

Example:
# Feature list: ProgramFiles AutoCon Desktop HelpFiles TextureFiles
Feature.ProgramFiles
Feature.AutoCon
Feature.Desktop
Feature.HelpFiles
Feature.TextureFiles
Feature.Demos

· Manufacturer-specific user data:
From the suggestion list in the file, select the user data (product catalogs for reinforcement or formwork catalogs) that should be installed.

Example:
# Vendor list: Ancon Ancotech Armaturis Lindab BarSplice Coupler DaytonSuperior Bartec Rolltec Erico Filigran Halfendeha Halfenhbs Hrc Line Register Peikko Philipp Reidbar Sah Schoeck Splice
Vendor.Ancon
Vendor.Ancotech
Vendor.Armaturis
Vendor.Lindab
Vendor.BarSplice
Vendor.Coupler
Vendor.DaytonSuperior
Vendor.Bartec
Vendor.Rolltec
Vendor.Erico
Vendor.Filigran
Vendor.Halfendeha
Vendor.Halfenhbs
Vendor.Hrc
Vendor.Leitungskataster
Vendor.Peikko
Vendor.Philipp
Vendor.Reidbar
Vendor.Sah
Vendor.Schoeck
Vendor.Splice

# Formwork: Meva1
Formwork.Meva1

2. Storage of the installation and the settings file on a share (optional)
In order to be able to roll out the Allplan installation efficiently on all computers, it is recommended to store both the Allplan setup and the settings file on a share in the network to which all relevant computers have access. See also the note on the full setup at the end of the FAQ.

3. Choice of installation option
You can choose between the following installation options:

· Quiet Installation: Installation takes place without user input being necessary.
· Passive installation: Installation takes place with reduced user input.

4. Installation
The installation is started in the unpacked 'Allplan' folder using the file 'Allplan_Installer.exe' using the following command line entries:

· For quiet installation:
Allplan_installer.exe /Settings <path to the settings file> /quiet

Example:
\\SERVER\Share\Subfolder\Allplan_Installer.exe /settings \\SERVER\Share\Subfolder\settings.txt /quiet

· For passive installation:
Allplan_Installer.exe /Settings <path to the settings file> /passive

Example:
\\SERVER\Share\Subfolder\Allplan_Installer.exe /settings \\SERVER\Share\Subfolder\settings.txt /passive
 
5. Modify the installation
It is also possible to modify the installation.
To do this, edit the settings file for the desired additional or components to be removed. Call the setup with the following parameters:

· For quiet installation:
Allplan_Installer.exe /Settings <path to the settings file> /quiet /modify

Example:
\\SERVER\Share\Subfolder\Allplan_Installer.exe /settings \\SERVER\Share\Subfolder\settings.txt /quiet /modify

· For passive installation:
Allplan_Installer.exe /Settings <path to the settings file> /passive /modify

Example:
\\SERVER\Share\Subfolder\Allplan_Installer.exe /settings \\SERVER\Share\Subfolder\settings.txt /passive /modify
 
6. Repair of the installation
It is also possible to repair the installation.
Call the setup with the following parameters:

· For quiet installation:
Allplan_Installer.exe /Settings <path to the settings file> /quiet /repair

Example:
\\SERVER\Share\Subfolder\Allplan_Installer.exe /settings \\SERVER\Share\Subfolder\settings.txt /quiet /repair

· For passive installation:
Allplan_Installer.exe /Settings <path to the settings file> /passive /modify

Example:
\\SERVER\Share\Subfolder\Allplan_Installer.exe /settings \\SERVER\Share\Subfolder\settings.txt /passive /repair
 
7. Uninstall
Uninstallation can also be done via passive or quiet installation.
 
Rufen Sie das Setup mit folgenden Parametern auf:
 
· For quiet installation:
Allplan_Installer.exe /Settings <Pfad-zur-Settings-Datei> /quiet /uninstall
 
Example:
\\SERVER\Share\Subfolder\Allplan_Installer.exe /settings \\SERVER\Share\Subfolder\settings.txt /quiet /uninstall
 
· For passive installation:
Allplan_Installer.exe /Settings <Pfad-zur-Settings-Datei> /passive /uninstall
 
Example:
\\SERVER\Share\Subfolder\Allplan_Installer.exe /settings \\SERVER\Share\Subfolder\settings.txt /passive /uninstall


HInt:
Of course, in the silent setup, the name of "Allplan_Installer.exe" must be adapted to the name that matches the version (e.g. Allplan_2023_0_4_Installer.exe).


Note on downloading the full setup from version 2023:
From version 2023 onwards, Allplan is installed using a minimal installer, which only downloads those components that are actually required for the installation.
If, for example, the complete installation package with all optional components is required to roll out the setup, it can be downloaded using the layout mode, which is described in the following FAQ.

https://connect.allplan.com/de/faqid/sc-000007942.html

 
Note on licensing:
Since there is no longer a license query in Allplan Setup from version 2022, this information cannot be provided. If a license server is in use, it can be set up on a computer and then distributed using the following procedure.

https://connect.allplan.com/de/faqid/sc-000007100.html


Download
- settings (1 KB)

Repair installation as of version Allplan 2022

Version:  Allplan 2022, Allplan 2024, Allplan 2023  | Last modified: 27.02.2024 14:42
 
rate

Question:

How can Allplan program data be repaired?



Answer:

The Allplan program files can be repaired via a repair installation.

To repair the Allplan program data, please proceed as described:
In Windows, select Start  > Einstellungen > Apps > Apps and Features.

Select the Allplan version (from Allplan 2022) for which you want to repair.
Select the "Change" button offered in the dialog that now appears.



The Allplan Setup Menu is started.
Select the "Repair" option here



You can then select the components to be included in a repair installation in the options of the Allplan installation dialog.
To perform the repair installation, select the "Install" button.


The repair installation will now be executed.


Importing DWG/DXF files

Version:  Allplan 2022, Allplan 2021, Allplan 2024, Allplan 2023  | Last modified: 28.02.2024 08:37
 
rate

Question:

How can I import a DWG/DXF file into Allplan?



Answer:

A DWG/DXF file always consists of the model space (design). In addition, the file can have one or more layouts (paper space). AutoCAD’s paper space is similar to the layout editor in Allplan; AutoCAD’s model space is equivalent to drawing file edit mode in Allplan (provided you work with only one drawing file).

You can use the following settings for import:

Import to a drawing file
For importing only the model space of the DWG file

Double-click an empty drawing file to select it. Then click File -> Import -> Import AutoCAD Data... -> Settings(click the icon showing the gearwheel).

Click Resetat bottom left to restore the default settings.
If you do not require 3D data, open the 'General Settings'tab and select 2D for the transfer mode. Open the 'AutoCAD specific' tab and select the 'Design (model space)' and'Check file during import' options.
Click OKto confirm the se