Support Forum

[Question] VS can't launch in Allplan 2021-1-9


HI!

In Allplan 2021-1-7 VS working properly.
After updating to Allplan 2021-1-8 I got a problem with Visual Scripting - it's self-closing every time and I cant complete any script.
After updating to Allplan 2021-1-9 VS doesn't launch anymore.
In attachment 2 trace files for 1-8 and 1-9 versions.

Please help to find the reason for such problems.

Attachments (1)

Type: application/zip
Downloaded 129 times
Size: 39,51 KiB

Show most helpful answer Hide most helpful answer

Quote by milandomkar
It has been a while when I used VS last time so I'm not sure if it worked in last allplan 2021 update. But generaly speaking in allplan 2021 it worked.
"PermissionError: [Errno 13]Permission denied: 'c:\\programdata\\nemetschek\\allplan\\2022\\etc\\visualscripts\\___pyp__'" - that seems to be a problem right?

It could cause the problem. As the file ___pyp__ is only a temporary file. Can you delete it and start VS again to check if it works?

Product Owner – Visual Scripting

1 - 10 (16)

We don't have a similar issue here. Could you please also upload the file allplan_python.out? That includes VS/PyP-related logs.

It is located at the same place where allplan.out is. By default:
C:\Users\<username>\AppData\Local\Nemetschek\Allplan\2021\Tmp\

Otherwise, you can try to reinstall the 2021-1-9 with the full installation package, and check if it works.

Product Owner – Visual Scripting

Attachments (1)

Type: image/png
Downloaded 19 times
Size: 32,78 KiB

Yes, please.
File in attachment

Attachments (1)

Type: text/plain
Downloaded 132 times
Size: 4,78 KiB

Have a look at the trace window: Is there a similar powersetting change listed:

APM #8013 Sun Jul 18 11:59:33 2021
APM PBT_POWERSETTINGCHANGE >>>
APM GUID_BATTERY_PERCENTAGE_REMAINING: prev=85 now=86
PowerStatus: ACLine=1 BatteryFlag=9 BatteryLife=86
APM PBT_POWERSETTINGCHANGE <<<

This leads on my laptop to self closing of visual-script-editor!

I've sent this issue to hotline 21/08/07, without any feedback!

The power saving behavior used to close VS-Editor prior to version 2021-1-9 automatically, if user wasn't active for a while. But that should be fixed in 2021-1-9 and it shouldn't cause VS-Editor unable to be opened.

For any VS/PyP-related issues, we recommend post directly in forum. If we can figure out the problem quickly, you may get feedback much sooner, than report it to hotline.

Product Owner – Visual Scripting

Hi,

please execute a full installation of the 2021-1-9.

The allplan_python.out shows that some of your files are not updated correctly.

Best regards
Horst

Hi!

I updated from the full installer 2021-1-9. And now VS launching normally. But objects don't appear (see video).

The same in the new file and project. Restarting of VS don't help

Attachments (1)

Type: video/mp4
Downloaded 121 times
Size: 3,73 MiB

in trace for version 2021-1-8 and -1-9 i saw this:

ComServerRegistered: current exe C:\Program Files\Allplan\Allplan 2021\Prg\NemAll_AllplanComServer10.dll different from registered NAllComServer C:\Program Files\Allplan\AllplanPrecast 2021\Prg\NemAll_AllplanComServer10.dll

normaly this should look like :
ComServerRegistered: exe C:\Program Files\Allplan\Allplan 2021\Prg\NemAll_AllplanComServer10.dll registered as NAllComServer

and also the lines Nemo mentioned

	APM PBT_POWERSETTINGCHANGE >>>
		APM 	GUID_BATTERY_PERCENTAGE_REMAINING: prev=64 now=65
		PowerStatus: ACLine=1 BatteryFlag=8 BatteryLife=65
	APM PBT_POWERSETTINGCHANGE <<<

maybe this help to analyse the issue

Allplan Webentwicklung

Private messages must be private. No support request via Private message.

I updated from the full installer 2021-1-9. And now VS launching normally. But objects don't appear (see video).
The same in the new file and project. Restarting of VS don't help

We checked your video. It seems the Allplan palette for VS didn't show up. Could you please upload the new allplan.out and allplan_python.out?

But in another video you posted here, you did create the object from VS. Does that mean, it happens occasionally? I'm a little confused here.

Product Owner – Visual Scripting

the other video was shot with a Planbar 2021 on my PC. And the problem exists in Allpan 2021 on my PC (i have a parallel installation of versions).
Currently, this problem is somehow self-fixed on my PC.

But another few users reported the same problem to me.
They have the same situation with Allplan 2021-1-8 and 2021-1-9.
Out files are attached

Some users have this problem when the interface is switched on Russian
For someone problem is the same for all languages

Attachments (2)

Type: application/zip
Downloaded 86 times
Size: 16,48 KiB
Type: application/zip
Downloaded 78 times
Size: 36,60 KiB
1 - 10 (16)

https://connect.allplan.com/ uses cookies  -  More information

Accept