Support Forum

Moving objects when performing GROUP_UNION [Solved]


Good afternoon
I find that when applying union results the vertical bars move image 1
in image 2 before applying the union.

Escrip image 3

Thanks in advance.

Attachments (3)

img
1.JPG
Type: image/jpeg
Downloaded 4 times
Size: 49,78 KiB
img
2.JPG
Type: image/jpeg
Downloaded 4 times
Size: 64,61 KiB
img
3.JPG
Type: image/jpeg
Downloaded 6 times
Size: 128,32 KiB

Show solution Hide solution

Toni,
To close the topic, click on "IsSolution" on the message where is the solution.
You can also click on "Helpful" where the message helped you...


1 - 7 (7)
  • 1

Hi Toni,

The problem comes from your TRANS functions in the script.
The best thing is only to apply TRANS for the moves between the elements in the groups.

And just before placing the group, you move (TRANS) where you want to finally place the result of the union.

Look at my comments in your script, you will understand exactly what I mean.


Attachments (1)

img
2020-08-30_14h19_58.png
Type: image/png
Downloaded 5 times
Size: 227,40 KiB

Good afternoon Bertand
Solved,
Sorry for the Smartparts basic questions
A trans question models from 0,0,0
Transx, when to use it?
thanks for everything

TRANSX is used to only move in the X axis, TRANSY and TRANSZ for Y and Z axes.
If you need to move in 2 or 3 axes, use TRANS.
This works only in 3D script.
In 2D script, use TRANS2.


Goodnight
Closed topic

Attachments (2)

img
1.JPG
Type: image/jpeg
Downloaded 4 times
Size: 58,50 KiB
img
2.JPG
Type: image/jpeg
Downloaded 4 times
Size: 71,72 KiB

Toni,
To close the topic, click on "IsSolution" on the message where is the solution.
You can also click on "Helpful" where the message helped you...


Is it possible to post the smartpart?

Gruß Jürgen

1 - 7 (7)
  • 1

https://connect.allplan.com/ uses cookies  -  More information

Accept