Support Forum

Allplan 2019 PythonParts Debugging using PTVSD error [Solved]

Hello everyone,
As a short introduction:
I am trying to make a few pythonparts using Visual Studio 2017 and Allplan 2019 and can't make the debugging work.
I tried using Visual Studio 2015 as well as i saw in another topic but nothing changed.

I am using ptvsd 3.2.1 and tried to use the original python environment that is installed with allplan and another one set in program files. (P.S. tried ptvsd 4.2.4 and it wont work with allplan current settings and 3.1.0, nothing changed)
The python version that i am running is 3.6.5.

As you can see in the fist picture (1) the debugging scripts starts to run but right after Allplan stops working and I can't find any process in Visual studio so I can attach the debugger.
I would really appreciate if anyone can help me get out of this issue.

Attachments (3)

Type: image/jpeg
Downloaded 33 times
Size: 166,00 KiB
Type: image/jpeg
Downloaded 29 times
Size: 132,34 KiB
Type: image/jpeg
Downloaded 40 times
Size: 243,49 KiB

Show solution Hide solution

Solved the issue.
You have to use Visual Studio 2017 15.7 not 15.9 and ptvsd

1 - 4 (4)
  • 1

Solved the issue.
You have to use Visual Studio 2017 15.7 not 15.9 and ptvsd

I use Visual Studio 15.7.6 and ptsvd yet I get this error. How did you fix it?

Attachments (1)

Type: image/png
Downloaded 32 times
Size: 169,09 KiB

Sometimes it helps if you write specify the ip and port manually instead of using localhost. Try to use PythonParts@

1 - 4 (4)
  • 1 uses cookies  -  More information