Search

Support Filter
Version:  Allplan 2017, Allplan 2021, Allplan 2020, Allplan 2019, Allplan 2018 |  Last modified: 27.02.2024 13:56
2 user(s) found this Knowledge Article helpful

Question:

How can I import DXF and DWG files that contain elements with large coordinates?



Answer:

Imported DXF and DWG files that contain elements with large coordinates can cause performance problems in Allplan. To avoid problems with this data, you have the following options:

Option 1: set an offset
Set an offset in the project. In Allplan 2011 and later, you can do this directly when you create a new project. For existing projects, you can specify offset coordinates later. To do this, select the File menu -> clickOpen Project-> select the relevant project -> open the shortcut menu and click Properties. (In Allplan 2009 and earlier, select the Tools menu -> Options -> Advanced Draft -> Settings tab). The offset can also be set automatically during the import, which is described in option 2.

Option 2: adjust center of gravity to: offset
When importing, select the Options -> General Settings tab (Advanced Transfer Settings tab in V2008 and earlier) and select the Adjust center of gravity to "Offset" check box. The system automatically sets an offset in the project. Consequently, the origin of the file (= center of the min-max-box) is set to the origin of the coordinate system. This option is not available if you have already specified an offset or if the data to be imported does not contain large coordinates.

Option 3: adjust center of gravity to: origin
When importing, select the Options -> General Settings tab (Advanced Transfer Settings tab in V2008 and earlier) and select the Adjust center of gravity to "Origin" check box.This moves the center of the file to the origin of Allplan’s coordinate system. As opposed to the previous option, the coordinates themselves are changed. Use this option only when you do not need to export the data again.

Option 4: adjust center of gravity to: off
This imports the data into Allplan; the coordinates are not taken into account. To optimize working with large coordinates, select the Options -> Desktop environment page -> Optimize working with large coordinates (in Allplan 2009 and earlier: Tools menu -> Options -> Global Options -> 'Miscellaneous' tab -> Optimize working with large coordinates). However, the larger the volume of data you create far from the origin, the slower the performance might get. In addition, you can can move the data to the origin using Allplan's "Move" tool and, if necessary, specify a corresponding offset later.



Note:

Using an offset (as described in the first two options) is usually the better solution. You edit the data at the origin of the coordinate system but - due to the offset specified - point coordinates are measured correctly. The offset set is automatically taken into account when you export and import data, and it applies to the entire project.
If you do not need to export the data with the same coordinates again, we recommend that you use option 3 - adjust center of gravity to: origin.

https://connect.allplan.com/ uses cookies  -  More information

Accept