Support Forum

[Frage] Variables Beschriftungsbild: Visual Basic Formel wird nicht auf allen Arbeitsplätzen gleich ausgeführt


Hallo!

Wir haben einen Plankopf erstellt, der u.a. eine Visual Basic Formel enthält, die in STD/Vbs/functions.vbs definiert ist und den Projektnamen aus diversen Projektattributen zusammensetzt.

Diese Formel funktioniert auf den meisten Arbeitsplätzen im Büro korrekt, aber auf einem PC wird kein Ergebnis angezeigt. (Allplan 2018.1.
Antivirus und Firewall habe ich bereits probehalber deaktiviert, leider ohne Ergebnis.

Hat irgendjemand einen Tip, woran es sonst noch liegen könnte, dass ein VBS Script nicht ausgeführt wird?

Danke und lg,
Stefan

Total BIM Consulting S.L.
Calle Gerardo Diego 6, Local A | 41013 Sevilla | Spain

Hilfreichste Antwort anzeigen Hilfreichste Antwort verbergen

wenn ich mich richtig erinnere, stammt das Büro aus Spanien. GGF: ist zwar die gleiche Excel Version installiert, aber unterschiedliche SPRACHE?

was auch immer das Script machen soll (so genau hab ich den Beitrag nicht gelesen),
ggf. sind da DEUTSCHE Formeln drinnen, die in spanisch() nicht exisiteren ..

Früher musste man die Formeln in englisch schreiben

also statt
WENN( "@123@" > 24 ; "m3" ; "m2" )

IF( "@123@" > 24 ; "m3" ; "m2" )

dann hat die Formel im deutschen UND englischen EXCEL funktioniert, aber auch im Italienischen und damit auch spanischem Excel.

siehe z.b. auch:
http://www.herber.de/forum/archiv/472to476/473718_Funktionen_aus_VBA_Code_von_deutsch_in_englisch_ue.html

Jörg (Velletti), Allplan Webentwicklung

Man kann mich Siezen oder Duzen. Wie derjenige mag. Und bitte beachten: Supportfragen zu Allplan bitte nur über das Forum stellen und bitte mir nicht als "Persönliche / Private" Nachricht senden. Die kann ich nämlich nicht weiterleiten.

1 - 10 (12)

Servus Stefan!

...muss nicht für das Funktionieren des VBS eine Excel-Version installiert sein? Bilde ich mir ein!

...habt Ihr da auf allen Rechnern die gleiche Version?

Gruß, Martin

Architekt Podsedensek ZT | A - 1060 Wien | Linke Wienzeile 4 | http://www.podsedensek.at

Auf allen Arbeitsplätzen ist die gleiche Excel-Version installiert, daran scheint es nicht zu liegen.

Aber Danke!

Total BIM Consulting S.L.
Calle Gerardo Diego 6, Local A | 41013 Sevilla | Spain

stimmt der eintrag in der regestry an dem rechner?
darf der rechner auf die datei zugreifen?

excel ist meines wissen für vbs nicht notwendig..

Der Pfad im Registry-Eintrag am betroffenen PC ist m.E. korrekt (s.Anhang).

Über den Windows Explorer kann ich die functions.vbs im Editor öffnen und bearbeiten und Allplan hat Zugriff aufs STD-Verzeichnis, bzw. ich kann über die Bibliothek z.B. Smartparts laden, die in STD liegen.

Gibt es eine bessere Methode, die Zugriffsrechte zu überprüfen?

Total BIM Consulting S.L.
Calle Gerardo Diego 6, Local A | 41013 Sevilla | Spain

Anhänge (1)

img
registry.JPG
Typ: image/jpeg
35-mal heruntergeladen
Größe: 38,12 KiB

ist der pfad wirklich gleich den anderen?
greifen alle über die IP auf den server zu?
ist der dateiname kleingeschrieben? wie in dem bild?

evt hat das auch mit den Sicherheitseinstellungen des Rechners zu tun: "Zonen" einstellungen

der beitrag hier -> https://www.mcseboard.de/topic/200819-vbs-script-l%C3%A4uft-nicht-mehr-vom-unc-pfad/ <- ist zwar schon steinalt, aber so was gibt es ja immer noch ..

Und ist zwar kein UNC Pfad bei euch aber auch eine IP Adresse wird sicher nciht als "Script läuft LOKAL" bewertet.
Evt. auch einfach mal das Script local ablegen, ob das dann läuft, das würde für meine Theorie mit den "Zonen" sprechen.

Jörg (Velletti), Allplan Webentwicklung

Man kann mich Siezen oder Duzen. Wie derjenige mag. Und bitte beachten: Supportfragen zu Allplan bitte nur über das Forum stellen und bitte mir nicht als "Persönliche / Private" Nachricht senden. Die kann ich nämlich nicht weiterleiten.

Hallo!

Erstmal vielen Dank für die Lösungsansätze - leider musste ich das Thema zeitbedingt erstmal liegen lassen.

Nach viel VBS-Googeln und Herumprobieren bin ich mittlerweile zu dem Schluss gekommen, dass es kein Netzwerkproblem zu sein scheint, da das VBS Script auch mit einem lokalen Registry-Pfad nicht funktioniert. (auf meinem Rechner - bei Kollegen läuft das Script einwandfrei)

Zudem ist das Script über die Command Line sowohl lokal als auch über Netzwerkpfad ausführbar, nur Allplan lässt mich nicht ran... :-|
Auch das Update auf Allplan 2019 hat keine Besserung gebracht.

Ich bin mit meinem Latein am Ende und dankbar für jeden neuen Denkansatz.

lg,
Stefan

Total BIM Consulting S.L.
Calle Gerardo Diego 6, Local A | 41013 Sevilla | Spain

könnte es sein, dass ein virenscanner dazwischenfunkt?
Bei der Pfadangabe groß/kleinschreibung? -> hier hatte ich - wenn ich mich recht entsinne - schon einmal merkwürdigkeiten.

Danke für die Tips.

Habe die Pfadangabe auf Schreibweise überprüft: Dort ist alles korrekt.
Auch das Deaktivieren des Virenscanners (Windows-Defender) bringt leider nichts.

Total BIM Consulting S.L.
Calle Gerardo Diego 6, Local A | 41013 Sevilla | Spain

1 - 10 (12)

Verwendung von Cookies:
Um die Webseite optimal gestalten und fortlaufend verbessern zu können, verwendet Allplan Cookies.
Durch die weitere Nutzung der Webseite erklären Sie sich mit der Verwendung von Cookies einverstanden.  -  Mehr Informationen

Schließen