Foro de Soporte Allplan

[Pregunta] Vincular con locales ¿no funciona para Smartparts?

Etiquetas:

Buenos días.
Ha llegado el momento de hacer las mediciones del proyecto y estoy intentando etiquetar elementos para obtener unos listados más informativos. Para todo lo que son macros, marcar la opción "Encadenamiento en Locales" les incorpora el atributo "Local_topológico" (@453@) con lo que cada línea de medición puede informar de la planta, grupo de locales y local en el que se ubica el elemento, lo que es muy útil para quien tenga que descifrar la medición. Incluso, lo que ha sido una agradable sorpresa que no me esperaba, si el Macro y el local están en archivos distintos, como, en mi caso, la instalación eléctrica.
Algunos de los elementos que utilizo son Smartparts. A pesar de marcarles la opción "Vincular con Local" tanto en las opciones del elemento insertado en el modelo, como en las opciones propias durante la edición del Smartpart, no presentan el mismo comportamiento que los Macros. El elemento se vincula con el local, lo que supone que se puede mover, copiar y !ojo! borrar junto con el local, pero en los listados de medición no incorpora el atributo @453@, con lo que no se etiqueta como a mí me gustaría.
Trabajo con la 2017 todavía.
Si alguien sabe cómo solventar este problema, se lo agradecería sinceramente.
Adjunto unas imágenes: algunos elementos para medir. Las luminarias (macros) se etiquetan bien. Los enchufes que son SMT no. He hecho un Macro con con los restos de la descomposición del SMT y ese sí se etiqueta bien. Tal y como se puede ver en le listado.
Un saludo.

Adjuntos (3)

img
Imagen 1.png
Type: image/png
Descargado 7 veces
Size: 23,89 KiB
img
Imagen 2.png
Type: image/png
Descargado 9 veces
Size: 6,73 KiB
img
Imagen 4.png
Type: image/png
Descargado 13 veces
Size: 29,33 KiB
1 - 3 (3)
  • 1

Buenos dias!

Esto me parece ser una cuestión del filtro SELECT de tu informe.

Yo he hecho una pequeña modificación sobre el report estándar "Resumen Smartparts" y me aparecen tanto Smartparts como Macros con su ubicación.

Adjunto el informe modificado.

Si quieres, mándame tu informe y hecho un vistazo.

Saludos,
Stefan

Total BIM Consulting S.L.
Calle Gerardo Diego 6, Local A | 41013 Sevilla | Spain

Adjuntos (2)

Type: application/xml
Descargado 28 veces
Size: 81,03 KiB
img
Captura.JPG
Type: image/jpeg
Descargado 7 veces
Size: 60,03 KiB

Solucionado con tu ayuda. Gracias.
En efecto, he cambiado en el informe el atributo @453@ por PARENT(@506@), "función del padre" (a veces solo decorativa) y el resultado es el que buscaba.
Adjunto el informe con la modificación. El formato es caótico porque solo lo utilizo como puente para pasar las mediciones a Arquímedes vía excel, con la intención que sea en solo informe. Pero hace su papel y lo voy adaptando y corrigiendo según detecto errores o carencias, que tiene todavía muchas.

Adjuntos (2)

Type: application/xml
Descargado 30 veces
Size: 36,58 KiB
img
Imagen 5.png
Type: image/png
Descargado 12 veces
Size: 23,54 KiB
1 - 3 (3)
  • 1

https://connect.allplan.com/ utiliza cookies  -  Aqui

Acéptalo