Ricerca

Support Filter
Versione:  Allplan 2017, Allplan 2021, Allplan 2020, Allplan 2019, Allplan 2018 |  Ultima modifica: 27.02.2024 13:56
2 user(s) found this Knowledge Article helpful

Domanda:

Come posso caricare file DXF oppure DWG con coordinate elevate?



Risposta:

Se il file DXF oppure DWG contiene elementi su coordinate elevate (ad esempio dati di rilievo catastale in coordinate Gauß-Krüger), dopo l'importazione in Allplan questo potrebbe influire sulle performance del programma. Per eseguire un import dei dati senza problemi procedere come descritto di seguito.

Possibilità 1: Impostare l'offset
Impostare un offset nel progetto. A partire da Allplan 2011 questo può essere definito già in fase di creazione di un nuovo progetto. Per i progetti esistenti, l'impostazione può essere effettuata a posteriori da File ->Apri progetto-> evidenziare il progetto -> menu contestuale Proprietà. (fino alla versione Allplan 2009 questo avveniva da Strumenti -> Opzioni -> Costruzioni avanzate -> scheda 'Impostazioni'). Al punto 2 è descritta una procedura per impostare automaticamente l'offset in fase di importazione.

Possibilità 2: Adatta baricentro a: Offset
Durante l'importazione, entrare nelle 'Opzioni' -> scheda 'Impostazioni generali' (fino alla V2008 'Impostazioni trasferimento avanzate') e attivare la casella di controllo Adatta baricentro a "Offset". In questo modo nel progetto viene impostato automaticamente un offset, che posiziona il baricentro del file (=punto centrale del Min-Max-Box) sul punto 0,0,0 del sistema di coordinate. Questa opzione non è disponibile se è già impostato un offset oppure se nel file da importare non ci sono dati con coordinate elevate.

Possibilità 3: Adatta baricentro a: 0,0,0
Durante l'importazione, entrare nelle 'Opzioni' -> scheda 'Impostazioni generali' (fino alla V2008 'Impostazioni trasferimento avanzate') e attivare la casella di controllo Adatta baricentro a "0,0,0". In questo modo il baricentro del file viene spostato sullo zero assoluto (0,0,0) del sistema di coordinate di Allplan. Al contrario dell'opzione precedente, vengono modificate anche le coordinate. Utilizzare pertanto questa possibilità solo se questo file viene utilizzato all'interno dell'ufficio e non deve essere nuovamente esportato nella stessa posizione (e quindi non ci sono vicoli rispetto alle coordinate territoriali).

Possibilità 4: Adatta baricentro a: Off
In questo caso i dati vengono importati in Allplan senza considerare le coordinate. Per lavorare su coordinate elevate è anche possibile impostare un apposita impostazione in: Opzioni -> Ambiente lavoro -> Ottimizza lavoro con coordinate alte( fino ad Allplan 2009: Strumenti -> Opzioni -> Opzioni generali -> scheda 'Altro' -> Ottimizza lavoro con coordinate alte). Questa impostazione influisce positivamente su questa problematica. In linea generale più i dati sono distanti dal sistema di origine (0,0,0), maggiori possono essere gli effetti sulle performance. Come ulteriore possibilità, è possibile spostare i dati in Allplan con la funzione 'Sposta' vicino al sistema di coordinate 0,0,0 e all'occorrenza impostare un offset corrispondente al vettore di spostamento selezionato.



Avviso:

L'utilizzo di un offset (con entrambe le procedure precedenti) è nella maggior parte dei casi la soluzione migliore. Modificare i dati nelle coordinate originali utilizzando delle coordinate che considerano l'offset impostato e che quindi vengono misurate correttamente. L'offset impostato viene considerato automaticamente in fase di esportazione e importazione. Questo vale per l'intero progetto.
Se i dati non devono essere ri-esportati nella stessa posizione, è consigliabile utilizzare la terza possibilità -> Adatta baricentro a: 0,0,0

https://connect.allplan.com/ utilizza cookies  -  Maggiori informazioni

Accetta