Support Forum

[Frage] Erweiterte Xref in der Z-Höhe vesrchieben. Gibt es da eine Möglichkeit?


Hallo zusammen,
ich habe mehrere Gebäudemodelle, die auf unterschiedlichen NHN-Höhen liegen und wollte die als erweiterte XRef zu einem Gesamtmodell zusammensetzen. Im Anfang wollte ich dort aber die Höhen der gebäude so haben, dass sie alle auf gleicher Höhe liegen, da eine Geländemodellierung bis Montag zeitlich einfach nicht drin ist.
Ich musste sie logischerweise mit der Ebenenanbindung an die Quelle absetzen, da ansonsten alle Geschoss übereinander gehangen hätten.

Gibts es einen Weg den abgesetzten XRef einen Delta-Wert in Z-Richtung zuzuweisen, damit sie der Einfachheit halber auf gleicher Höhe erscheinen? Falls nicht, kennt jemand einen anderen Trick, wie man die Gebäude mit unterschiedlichen NHN-Höhen temporär alle auf einen gleiche EFH bekommen kann?

Vielen Dank und sonnige Grüße

Fredo

1 - 9 (9)
  • 1

Hallo Fredo!

Kommst du mit dieser Option bei Ablegen der X Refs ggf. auf mehreren Teilbildern nicht zum gewünschten Ergebnis?
Gruß

Stefan

Anhänge (1)

img
X Ref.png
Typ: image/png
18-mal heruntergeladen
Größe: 9,35 KiB

Hi Stefan,
ja, das wäre eine Lösung,aber sehr aufwendig, da die Geschosshöhen variieren und für jede Referenz ein eigenes neues Ebenenmodell erstellt werden müsste , glaube ich jetzt ohne Versuch zumindest, welches sich dann auf eine einheitliche Höhe von 0,00 beziehen müsste. Wäre wahrscheinlich eine Lösung, aber viel Arbeit! Habe demnächst 9 Gebäude, die so arrangiert werden müssten. Über einen Delta-Wert für jede einzelne XRef wäre das schnell gelöst und alle würden - trotz unterschiedlicher, realer NHN-Höhen - schnell auf einem platten Modell platziert werden können. Aber anscheinend gibt es die Funktionaltät nicht, oder?

Nächtliche Grüße

Fredo

Ich bin am Ende!
Jetzt habe ich folgendes gemacht, um die Referenzen aller Gebäude auf ein Null-Niveau zu bringen:
Ich habe neben dem eigentlichen Ebenenmodell für das jeweilige Gebäude ein weiteres Ebenenmodell erstellt, in dem ich die Erdgeschossfussbodenhöhe dann angeglichen habe. In diesem fall musste das Gebäude um 30cm nach unten rutschen. So weit so gut.
Referenz mit Ebenen nach Ziel eingestellt funktioniert. Was aber anscheinend mit Erschrecken nicht erkannt wird, sind die angelegten Abstandsflächen für die Höhe der Attika roh und fertig.
Kann es wirklich sein, dass man bei der Einführung der Abstandsflächen die Referenzierung vernachlässigt hat?
Hat einer einen Trick, ohne, dass ich die Attika wieder an normale Ebenen hängen muss?

Sonnige Grüße

Fredo

Anhänge (3)

img
Referenz nach Quelle.jpg
Typ: image/jpeg
7-mal heruntergeladen
Größe: 211,13 KiB
img
Referenz nach Ziel.jpg
Typ: image/jpeg
7-mal heruntergeladen
Größe: 206,03 KiB
img
Ebenenmanager.jpg
Typ: image/jpeg
8-mal heruntergeladen
Größe: 267,62 KiB

... es ist wirklich wahr, dass eine Referenz mit Ebenenanbindung nach Ziel die Abstandsflächen einfach ignoriert!
Ich bin leider mal wieder auf den Boden der Tatsachen zurückgeholt worden oder ich mache einen entscheiden Denkfehler.
Im angehängten Bild hab ich mal eine Attika in Bezug zur unteren Ebene des Staffelgeschosses eingegeben und schwups: es funktioniert.

Den Bug sollte Allplan also möglichst schnell beheben oder, wie oben gewünscht, einen Deltawert für die Höhenkorrektur von Referenzen einführen. Dann könnte man sich das ganze Anlegen von weiteren Ebenenmodellen ersparen und mite einem Klick wären die Gebäudemodelle zwecks einfacherer Animation auf einem Niveau.

Bin mal wieder sauer, da am Montag Abgeb ist!

Gruß

Fredo

Anhänge (1)

img
Referenz nach Ziel1.jpg
Typ: image/jpeg
6-mal heruntergeladen
Größe: 296,28 KiB

Servus,
wenn du das nur temporär brauchst könntest
du ja versuchen mal das Ganze Modell als IFC
zu exportieren und dann woanders wieder einzulesen.
Die Koten sollten dann sämtliche Absolut sein.
Dann könntes Du die einzelnen Gebäudeteile einfach
mit dz verschieben.
Versuch wärs wert.
Gr.
Kirk

... Anbindung von Elementen (hier Deckel auf Aufzugsschacht) geht auch nicht! Toll!

Anhänge (2)

img
Anbindung an andere Geschossebene.jpg
Typ: image/jpeg
10-mal heruntergeladen
Größe: 353,24 KiB
img
Anbindung an andere Geschossebene geht…
Typ: image/jpeg
7-mal heruntergeladen
Größe: 373,20 KiB

Hi Kirk,
wahrscheinlich ein guter Vorschlag, aber ich habe jetzt mittlerweile alle bauteil an die normalen Ebenen angehängt und jetzt funktioniert es. Mit IFC kenne ich mich noch gar nicht aus. Bin aber zur Zeit zu sehr unter Zeitdruck.

Trotzdem vielen Dank für die Hilfestellung!

Gruß

Fredo

... Bezugsebenen (z.B. für Brüstungshöhen) funktionieren auch nicht bei Anbindung Ebenen an Ziel.
Ich werde mich jetzt komplett von den Referenzen verabschieden, aber gelinde gesagt die Schnau.. voll!
Alle Brüstungen liegen auf Unterkante Geschossebene! Absoluter Wahnsinn!

Bis dann

Fredo

1 - 9 (9)
  • 1

https://connect.allplan.com/ verwendet Cookies  -  Mehr Informationen

Akzeptieren