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					Your frequently asked questions – and our solutions

Our technical support team has been asked lots of questions by Allplan users over the years and our solutions have been stored in a knowledge database.

As a Serviceplus customer, you can search the full database for the answers you need.
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			Question:

How can I fix Allplan program data?


Answer:

You can fix Allplan program data by renaming the program folders and installing an update.
Due to the new names, Allplan cannot find the resources during the update. Consequently, it creates new resources.

To fix Allplan program data, do the following:

You need the latest installation package for your version.
You can download this package from Allplan Connect (www.connect.allplan.com)
Copy the zip file to the local computer and unzip the file.
	Open the Services application of the Allplan version you want to fix.
	Select Service -> Windows Explorer -> CAD program folder.
	Rename the "PRG" folder "PRG_OLD". If Windows Explorer tells you that a file is still in use, restart the computer and try again.
	Start the *.exe file of the installation package you just unzipped.
	Select "Update installation".
	When Setup prompts you for the license, select "Current license file" or "Use active license".
	Select "Minimum" for the Setup type.



Allplan gets new program resources during installation.
As soon as the installation is complete, you can test how Allplan behaves.


Note: 

If you are not sure, give these instructions to your system administrator.
Keep in mind that you install the version of the installation package you downloaded. This means that you may have to reinstall any subsequent hotfixes.
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			Question:

How can the program "Codemeter Control Center" be installed manually.


Answer:

Exit Allplan.

A current and released version of "Codemeter Control Center" can be downloaded from the following link.

https://webdrive.allplan.com/s/4LrjrymoxESzC6p

The program is located in the folder.
/Allgemein/Wibu/

(Click on the three dots to the right of the file size and select download)


Start the file "CodemeterRuntime.exe" bypassing the user account control. To install, activate the file with the right mouse button and select "Run as administrator".
Confirm all messages in the setup, as well as the default settings with 'Next'.
Codemeter Control Center will then be installed.


Note:
If you are using an Allplan license server, the Codemeter Control Center program is not only available on every Allplan client, but also on the server running the Allplan license server.
Install Codemeter Runtime on your license server in the same way.
Please also note the following instructions for the license server.
https://connect.allplan.com/en/faqid/20200925120630.html
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			Question:

How can I update cross-section catalogs (Bars & Mesh) or install country-specific cross-section catalogs in Allplan 2011 and later?



Answer:

To install and save cross-section catalogs in Allplan 2011 and later, select Tools -> Defaults -> Cross-Section Catalogs. A dialog box opens. You can find a folder symbol and a disk symbol at bottom left.

To install cross-section catalogs, use the folder symbol. Another dialog opens, where you can select the cross-section catalog file you want to install. Select the file to be installed and click "Open" to confirm. This installs the corresponding cross-section catalog, which you can now use in Allplan.
To install country-specific cross-section catalogs, select the "Ing" folder, which was created when you installed Allplan. You can find it in the Allplan installation path (e.g., c:\Nemetschek\Allplan 201x\New\Ing - more information on the Allplan installation path is provided below in the "Notes" section).
This folder includes the country-specify cross-section catalog files.

To save a custom cross-section catalog, use the disk symbol. Another dialog opens, where you can select any folder to save the cross-section catalogs currently used in Allplan.



Note: 

To update cross-section catalogs, you may need administrator privileges. If necessary, log on as an administrator before you start the update.

To use the cross-section catalogs for a specific project only, set the path settings for the cross-section catalogs of this project to project before you install the cross-section catalogs. In Allplan, open the "File" menu and select "Open Project..." Click the corresponding project with the right mouse button. Select "Properties". A dialog box opens. In the "Path settings" area, set the "Bar and mesh cross-section catalogs" to "Project".

To determine the path where Allplan is installed, use the Services application and select Service -> Hotline Tools-> showcfg. The Services application window shows the path of the Allplan installation folder.

The following abbreviations are used for the country-specific cross-section catalogs in the file names (axyzqusr.txt):
aut Austria
bel Belgium
bra Brazil
bul Bulgaria
deu Germany
eng England
fra France
hol Holland
hrv Croatia
ita Italy
kor Korea
pol Poland
rum Romania
rus Russia
slk Slovakia
svn Slovenia
swi Switzerland
tch Czech Republic
ung Hungary
usa USA
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			Issue:

You want to get an overview of which Product Keys are valid for your respective workstations. Which ones are already assigned and on which of your computers the licenses are activated


Answer:

You can find a summary of this information in our Allplan Connect service portal 
(only possible with admin access to your company network, normal users in Allplan Connect do not have this access):

Call up the following link and log in to Allplan Connect.

https://connect.allplan.com/de/admin/lizenzverwaltung/lizenzverwaltung-2016.html

On this page you can view the following information:

	WS/License number
	Product
	Product key with Allplan package
	A symbolic indicator whether the license is activated or free. The up arrow means the license is activated, the down arrow means the license is free.
	The last change when the license (or the last license update to the license) was activated.
	CodeMeter Container, in which Codemeter Container the license with this product key is activated on your computer. 


But there is more information available:

	By pressing the button "Get license details for this product key" you can also view the computer name on which the product key is activated and other details such as expiration date and options.
	By pressing the button "Get license details for all product keys" this is done for all your product keys. 


Note: Since it is a live query each time, it may take a few seconds before the result is displayed. 

The license overview in Allplan Connect always gives you an up-to-date overview of who in the office is currently using which license and which license may also be free and can now be used.

Additional tip: You can find out the computer name of your computer quickly and easily using the Allmenu/Services. The computer name is displayed directly there


 



Note: 

Please note that no license can be activated or deactivated via this page. You can only activate a license directly on the computer on which the license is to be used. 
For instructions on how to transfer a license or activate it on another computer, please refer to the following instructions.

https://connect.allplan.com/de/faqid/20150618131629.html
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			Question:

How can I install a hotfix?


Answer:

Allplan automatically downloads hotfixes and installs them the next time you start Allplan.
To define settings in Allplan, open the ? menu and select Update Allplan.

Click the Find now button to find updates and install them the next time you start Allplan. 


Notes:

1. Downloading hotfixes manually

You can also download hotfixes manually.
Open our homepage 
(http://www.connect.allplan.com) and select
Downloads. 

The current hotfix and previous hotfixes are available for download.
Before you can download data, you must log in to Allplan Connect 


2. Installing hotfixes downloaded manually

You can install the hotfixes downloaded by double-clicking the file. Make sure both Allplan and the Services application are closed.
Hotfixes are installed one after the other in the correct order. In other words, you must download and install Hotfix 2014-1-1 before you can install Hotfix 2014-1-2.


3. Working with Workgroup Manager

If you work with Workgroup Manager and another user has already downloaded the hotfix, you can see the following message:

There are currently no updates available.

In tis case, the hotfix is in the Downloadfolder on the server. In Allplan select ?-> Update Allplan. Choose one of the following options to install the hotfix the next time you start Allplan:

	Install updates automatically-> the next time you start Allplan, the program will install the hotfix without asking you again.

	Download updates, install manually (recommended)-> the next time you start Allplan, a dialog box opens and you can decide whether you want to install the hotfix.


The default setting is
'Download updates, install manually (recommended)'.
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			Question:

Allplan does not react promptly or seems to hang after I have selected the "Open on a Project-Specific Basis" or "New Project, Open Project" tool.

One of the following virus scanners is running: Trendmicro, McAfee, Kaspersky, Avira, F-Prot and others.
What can I do to solve this problem?



Answer:

Check whether updating the software of the virus scanner solves the problem.

If it doesn't, configure the real time scanner of the virus scanner so that it no longer scans the program folder and data folder of Allplan. 

Start the Services application. Make a note of the following paths displayed in the Services application window:

Program folder                           
General program data
Central file storage folder

Define these folders as exemptions in your virus scanner.

In addition, add the paths listed below to the list of exceptions:

C:\Program Files\Allplan\AllplanUpdateLauncher 20XX\*.
C:\Users\Windows Username\AppData\Local\Nemetschek\Allplan\20XX\Tmp\*.
C:\Users\Windows Username\AppData\Local\ALLPLAN_GmbH\*.

Please note that the subfolders of the paths given in the list must also be included in the configuration.

Bear in mind that virus scanners may be installed on the server and the clients (provided you work with a server).
For more information on the virus scanner, contact the manufacturer.

Addition:
In addition, also configure the setting for licensing.
Define the exception in your virus scanner for the "Codemeter" folder. You will find this under:  

C:\Program files (X86)\Codemeter.
C:\Program files\Codemeter
C:\ProgramData\CodeMeter 
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			Note: 

You can help the technical support team to process your request by generating a support request with the Hotinfo program and sending it to us.

The generated support request will help to avoid unnecessary questions and delays, as it automatically contains all necessary information pertinent to the problem in question.


Procedure: 

The Hotinfo program is installed along with Allplan; you can start it over the following ways:
1. Start -> All Programs -> Nemetschek -> Allplan [version number] -> Hotinfo [version number].
2. Allplan -> ? -> Generate support request (Hotinfo)
3. Allmenu/Services -> Service -> Create Support request (Hotinfo)


Select the team with whom you wish to communicate:
Choose the relevant entry, for example, Technical Support Allplan. The email address of the selected team is entered automatically.

Select the areas on which you have questions:
Please select the question that is pertinent to your support request. 
You only need to select question 2 when Allplan support is requesting it from you.

01. General inquiry
02. Inquiry with Allplan logging

Note on question 02:
If you have selected question "02. Inquiry with Allplan logging", you can start Allplan straight form the Hotinfo after the questions. 
This will generate and attach a log (trace). 
Start Allplan by clicking on the button “Start Allplan”
Carefully reproduce the problem – for example, perform the steps that lead to the failure. 
Then click "Next" to generate the support request with the trace. 
You can click the "Take screenshot" button at any time while Allplan is running in logging mode. This way, you can quickly and easily save any error messages that may be displayed.

Enter your contact address:
Please enter your name, telephone number and email address
so that the technical support team can contact you.

Please describe the problem:
Describe the problem in detail (for example, include the exact wording of error messages).

Select the files you want to attach to the email:
You can include additional files with important information such as damaged drawing files, NID files or other files. 

Note:
These files are only attached to the email when you send the Hotinfo by clicking “Finish” -> Option “Start email program…" or send it to us over File -> Send Message...".
See note further down.

Create the screenshots you want to attach to the email:
You can use the "New screenshot" button to take screenshots of the entire screen and send them as a file attachment to the Hotinfo.

Note:
These files are only attached to the email when you send the Hotinfo by clicking “Finish” -> Option “Start email program…" or send it to us over File -> Send Message...".
See note further down

Finish
Here you have the possibility over the pre-selected option "Start Email program..." to start your email program with the created Hotinfo, the generated files as a file attachment and the correct destination address. You only need to press 'Send'.

Over option "Open Hotinfo file to save it..."you can open the support request, save, and send as an email attachment to support.de (please no spam) @ (please no spam) allplan.com, if no e-mail program is installed locally.
In this case, make sure to attach in addition to the support request all additional files also. Attach the "attached files" and "generated screenshots" independently as attachment to your email.
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			Question:

How can I check out a computer and continue to work as a normal CAD user with my usual settings and permissions?



Answer: 

Install the "Microsoft Loopback Adapter" driver.
This driver is necessary so that network services are running on the computer all the time.
Go to Allplan Connect for a detailed description: https://connect.allplan.com/en/faqid/000162ae.html


Sign in as the Allplan administrator to the computer.


Step 1: add the computer to workgroup manager
You must add the computer to the workgroup so that you can store data (data server) on this computer. Do the following:

Create data folders:
Create a folder - for example, “Nemdata” - on the computer and share it (full control).
Create the “Allplan” subfolder in this folder. Create two subfolders - “usr” and “prj” - in the Allplan folder.
In this example: “...\Nemdata\Allplan\prj” and “...\Nemdata\Allplan\usr”

To share a folder for the Allplan file storage

	Start File Explorer on the computer that you want to use for file storage and switch to the folder that you want to share (in this example, the “Nemdata” folder).
	Right-click the folder that you want to share and select Give access to -> Specific peopleon the shortcut menu.
	Select Everyoneand click Share.
	


Add computer:
	Start the Services application as the workgroup administrator.
	Click and select Manage computers and projects.
	Click the Add any computer to Allplan workgroupicon and select the computer that you want to add.
	Select the “Allplan” subfolder under the share and click “OK” to confirm. This computer is now listed under workgroup server.




Note:If you have problems adding the computer to workgroup manager, read the following instructions:
https://connect.allplan.com/en/faqid/20200317162849.html



Step 2: define project owner
A user can only move a project if the user is the owner of this project.
The ownership of a project can only be changed by an Allplan administrator (or the owner of the project).
Allplan -> File -> ProjectPilot -> 
Go to the “Projects” node, right-click the required project and click Propertieson the shortcut menu.
Define the owner.


Step 3: move projects
Sign in as the user who wants to check out the computer.
Select the Services application -> Workgroup Manager -> Manage computers and projects.
Click the main server and select the project that you want to move.
Drag the projects one after the other to the computer to be checked out.

Important note: You can take projects with you in several ways.

1. You move the project to the computer.
Move project: Drag the project to the destination computer, or open the shortcut menu of the project and click “Cut”. After this, open the shortcut menu of the destination computer and click “Paste”. 
After you have checked in the computer, move the project back to the server so that it is available to all and included in backups again.

2. You copy projects. Click a project, select and hold the Ctrl key and drag the project to the destination computer. Or: Open the shortcut menu of the project and click “Copy”. After this, open the shortcut menu of the destination computer and click “Paste”.

You can continue in two ways: Lock the original project on the server to protect it from changes. Consequently, nobody in the office can work on this project, but it is still on the server. When you check in the computer again, you unlock the project on the server, delete the project and copy your copy back to the server if you have changed the project.
Alternatively, both projects remain active. Consequently, both the project copied and the original on the server can be worked on. In this case, however, you must adjust the data manually when you are back in the office by copying the changed drawing files of the projects by using ProjectPilot.




Step 4: check out the computer
Select the Services application -> Workgroup Manager -> Manage computers and projects.
Click your computer and then click Check outin the lower-right area.
Confirm the message that tells you that there are still user folders on the computer to be checked out.
Enter a comment and click OK. Users in the office see this comment when they try to access a project that is on the computer that is checked out.
Specify the parts of the office standard you want to copy to the computer and click OK to confirm.
The first time you check out the computer, you must copy the office standard once so that the entire STD folder is on this computer. This is no longer necessary when you check out the computer afterward because the contents of the STD folder do not change very often.


Conclusion: 

You can now remove the computer from the network and work on your projects when you are out of the office. To make sure that the projects are not changed in the office in the meantime, the projects that are on the computer checked out are locked for the CAD users on the network. These users see the comment you entered when you checked out the computer.



Notes:

	You can only check out a computer to which you are signed in. You cannot check out another computer over the network.
	Projects on this computer must be neither locked nor in use.
	For installations with license server: You must also borrow a license from the license server for the computer you want to check out.


Description of the Nemetschek Softlock license server:
https://connect.allplan.com/en/faqid/20120321113607.html

Description of WiBu license server: 
Allplan 2016: https://connect.allplan.com/en/faqid/20150618134322.html
Allplan 2017 and later: https://connect.allplan.com/en/faqid/20160523165423.html
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			Question:  

How can I import data from an earlier version? 



Answer: 

You can import data from the last three Allplan versions. 
Consequently, the following import operations are possible:

Target version <- import possible from version

2017  <-  2014
2016  <-  2013
2015  <-  2012
2014  <-  2011
2013  <-  2009
2012  <-  2008
2011  <-  2006
2009  <-  2005
2008  <-  2004
2006  <-  2003
2005  <-  17
2004  <-  16

We cannot guarantee that data created in older versions can be imported and edited. The conversion of older data may be incomplete, which may affect intelligent components in particular.


1. Archived data from an earlier version (not older than three previous versions):

There are two ways to convert the data to the current version:

	Import the project backups created and archived using the 
Services application -> Data Backup -> Import -> Projects.
After importing the projects, convert them by opening each project once.
	Import the backups archived using the 
Services application -> File -> Restore documents of any version to '...\Extern'.
The data are written to the external path. 
You can now process the converted data in ProjectPilot.



2. Archived data from an older Allplan version (older than three previous versions):

	See whether you can use the approach described in step 1 to import the old projects.
	If available, it is a good idea to install an old Allplan version. Import the backups created and archived into this old version and convert the projects using the Services application. If you have imported a complete project backup, convert the data by opening each project once. When finished, repeat this process with a newer version (up to three versions later) until the data are up-to-date.
	If an old Allplan version is not available, you can also have the data converted by Allplan. Please note that this service is not free of charge. Please contact Technical Support -> support.de@allplan.com.




Notes: 

	You can convert the data of all projects at once. Read the following FAQ in Allplan Connect: https://connect.allplan.com/en/faqid/20090408124904.html
	If enough hard disk space is available, you are advised to keep and maintain the projects so that Allplan automatically converts them to the current version whenever you upgrade.
	If there are project-specific smart symbol catalogs, you should open the smart symbol catalog once to convert the data.
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			Question:

How can I transfer the license permanently to a new computer?
How can I temporarily transfer the license of a registered computer to a different computer? 
How can I interchange the licenses of two registered computers? 



Answer:

If you activated the license online by entering a Product Key, you can return the Product Key and then use it for a different computer. You can return and activate the license only if the computers have Internet access. The computer where you want to return or activate the license does not have to be online all the time. It is enough if it is online while you are returning or activating the license.


Returning a license
To return a license in online mode

	Open the 'License settings' dialog box: Services application -> Utilities -> License settings
	Write down the Product Key for the license you are returning.
	Click License activationon the left. Then click the license you want to return.
	Click Return license. 


You can now activate the license on a different computer.


Activating a license
If you want to transfer the license permanently, you can activate a license while you are installing Allplan or after you have installed Allplan. By activating a license, you connect the license with the new or other computer. As a result, you can start Allplan on this computer.
If you want to transfer the license only temporarily, install Allplan as a viewer on the second computer and
activate the license later.
To activate the license during installation:
Start Setup and follow the instructions displayed.
	In the 'Installation Option' dialog box, select the 'Enter Product Key' option and click 'Next'.
	Enter your Product Key.
	Click 'Activate license'.


To activate the license after installation:

	Open the 'License settings' dialog box: Services application -> Utilities -> License settings
	Click License activationon the left.
	Enter your Product Key.
	Click Activate license.



Here comes a practical example:
If you want to use a Product Key for running Allplan on two or more computers, you must use computer A to return the license before you can use this license with computer B. To return the license, open the Services application -> Utilities -> License settings -> Return license. If this computer always uses the same Product Key, you can find this Product Key in the box below License activation. This box always displays the last Product Key entered.

If you switch between several licenses, it is a good idea to save the Product Keys used in a text file on the desktop. This way, you can copy the Product Keys quickly and easily to the license settings.


Note: When license cannot be returned due to defect
If your computer has a defect and does not start anymore, or your hard disk has crashed and you had to install a new one, we need a statutory declaration from you. You will receive this declaration after your situation has been checked by the technical support team. Please contact your local Allplan Support with a brief description of what happened. 


Further Notes:
You can also find your Product Key in Allplan Connect. Go to http://connect.allplan.com/license
Click Profile -> License administration. 
Only administrators can use this function.
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			Question:

How can I give individual users the right to see and select specific seats on the license server? And how can I deny users this right?
Sometimes, it may be necessary that a specific user does not see the seat with, for example, the terrain option so that this user cannot use this seat inadvertently. 


Answer:

Using WebAdmin, you can give users rights for specific seats on the license server.
Please note the following points:

1. Before you start, check that at least CodeMeter Version 6.50 is installed on the license server.
Start CodeMeter Control Centeron the server.
To do this, use the Windows start menu and select CodeMeter -> CodeMeter Control Center. As an alternative, open Search by clicking the Search button on the Start screen. Enter Codemeter and press ENTER. Select Help -> About to see which version of CodeMeter is installed. If the version displayed is older than version 6.50, you must install the latest version of CodeMeter Control Center. Go to the following website
and download the CodeMeter User Runtime for Windowsprogram.

https://www.wibu.com/de/anwendersoftware.html

2. Open WebAdmin. Start CodeMeter Control Centeron the server again.
To do this, use the Windows start menu and select CodeMeter -> CodeMeter Control Center. As an alternative, open Search by clicking the Search button on the Start screen, enter Codemeter and press ENTER. A dialog box opens. Click WebAdminat bottom right.

Or
Enter Localhost:22350in the address bar of your browser.

3. Go to "Configuration -> Server -> License Access Permissions".
Select Mode: Advanced.

4. Go to "Advanced Mode Configuration -> Specific access rules -> Add Firm Code"and select "6000100 - Allplan GmbH". Click Add. "Specific access rules"now inlcude "6000100 - Allplan GmbH".






5. Click "Add Product Code"to select the seat for which you want to define access rights. However, this is only possible if the "Distinction based on Product Item Text" check box is selected. 
The "Note" section below in this FAQ lists the abbreviations given at the end of each seat. These abbreviations represent the license contents.
Select the required seat and click "Add" again. Repeat these steps to assign more seats.






6. After having defined the product code, you can now assign an access rule. 
By default, all users are allowedto access this seat. 
Select the product code you just defined and click "Add new access rule". 
Click "User" and enter the required user.
When you click in the field next to "User", you can see all available users with their domain names.
Select the user or enter the user manually. For example, enter DOMAINNAME\SSample and select the right you want to assign to this user by clicking "Allow" or "Deny".

If the default setting is "Allow", you can thus deny users access to the license. If the default setting is "Deny", you can thus allow users to access the license again. 
You can add more rules. When you have configured all rules, click "Apply" to apply the changes.

7. You need to restart CodeMeter Service so that the changes take effect. 
To do this, select CodeMeter Control Center -> Process -> Stop CodeMeterServiceand then click Restart CodeMeter Service.Before you restart the service, make sure all users have closed Allplan. 


Information: 

Client access can be defined by one of the following parameters: computer name, IPv4 subnet, user name or group name. 
Enter the required parameter in the corresponding field. If you use an active directory, the program auto-completes entries in the "User" and "Group" fields.


Here comes a practical example:

Think about which setting is most useful to you. For example, you have two seats: seat 01 with 7 architecture licenses and seat 02 with 1 architecture license and 1 terrain license. Only two specific users should be able to use seat 02. If you want to deny all other users access to seat 02, you need to add seat 02 to specific access rules and define a rule for this seat 02. First, set the default setting to "Deny". Then, add these two users and select or "Allow" for these users. As a result, all other users can only see seat 01 and these two users can see seats 01 and 02. 

However, if you want that these two users can only see seat 02, you need to add both seats to specific access rules and define a second rule for seat 01. Add these two users to this second role and select Deny for these two users. The default setting, which applies to all the other users, is still Allow. As a result, all other users can see seat 01 and these two users can only see seat 02.


Note: 

The following abbreviations are used:

T Terrain 
B Bamtec 
W Workgroup 
K Key Plan 
M Bridge Modeler 
L Cadastral plans for conduits 
S Language option 
V Visualization 
A Architecture option
E Engineering option

Here are some examples:

Architecture:
"Allplan Architecture 2017”

Architecture + Terrain 
"Allplan Architecture 2017 T"

Architecture + Bridge Modeler 
"Allplan Architecture 2017 M"

Architecture + Terrain + Bridge Modeler 
"Allplan Architecture 2017 TM"
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