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					Your frequently asked questions – and our solutions

Our technical support team has been asked lots of questions by Allplan users over the years and our solutions have been stored in a knowledge database.

As a Serviceplus customer, you can search the full database for the answers you need.
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			Question:

After I updated Windows (8 to 8.1; 8.1 to 10), Allplan only starts as a viewer. What can I do?


Answer:

Windows update corrupts Nemetschek Softlock License Manager. 
To fix Allplan, do the following:

You need the latest installation package for your version.
You can download this package from  our webdrive

https://webdrive.allplan.com/s/4LrjrymoxESzC6p

You can find the installation packages in the following path: 
Allplan/"Version"/Installationspaket/

Copy the zip file to the local computer and unzip the file.
Start the installation and run an update use our temporary license file.

You can download the temporary license from Allplan Connect:
https://connect.allplan.com


After the installation, you can open License Manager again (Services application -> Utilities -> License -> License Manager). Next, install the temporary license (*_psd.nslock): "Install - Install license"
Note: the status of the temporary license is set to "Expired".

Next, create a new registration request. 
To generate a registration request, do the following:

Open License Manager (Services application -> Utilities -> License -> License Manager). Select the license entry for your seat and click "Request license". 
Follow the instructions displayed on screen. Complete the form. Do not forget to enter your email address. 

Check that the Client ID and CD Key are correct.

Send the registration request to: register@nemetschek.de.
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			Question:

I have several licenses, but I want to use a specific license to start Allplan. How can I do this? 



Answer:

Open the license settings on the client:

Services application -> Utilities -> License settings -> License selection

You can see all the licenses that are available on the network. You can control license selection as follows:


Select the check box in front of a license to select this license as a favourite. You can mark as many licenses as you want. Allplan will then prefer these licenses. Click [image: ]
to select one or more licenses Allplan is not to use.

Make settings as you need. 

If you do not select any license or if you have selected several favourites, Allplan will automatically use the first free license it finds.


Note:

Check which licenses are available.
Available column: 
This column shows how many licenses are still available. For example, 3/5 indicates that 3 out of 5 licenses are still available. Click the dropdown arrow to see a list of users currently working with a license.
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			Question:

Where can I find the system requirements and the system test for Allplan 2021 



Answer:

Under the following link you will find comprehensive information on the topics:

- system test
- System requirements
- Graphic cards


www.allplan.com/info/sys2021




Note:

The following link contains computer models tested and recommended by Allplan:

https://connect.allplan.com/support/certified-hardware.html
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			Frage:

Warum kann der Cinerender nicht gestartet werden?



Antwort:

Prüfen Sie bitte, ob auf Ihrem Computer das Programm "ManyCamService.exe" installiert ist. Deaktivieren Sie dieses Programm gegebenenfalls.



Hinweis: 

in der Firewall wurde der Cinerenderer für eingehende sowie ausgehende Regeln bereits "whitelisted" .

Mögliche Ursache für das Phänomen:
Das Programm "ManyCamService.exe" reagiert auf den Port 1234, welchen Allplan bei Starten des Cinerenderers adressiert und behindert so die Kommunikation zwischen Allplan und Cinerenderer.

Der Port 1234 ist der für VLC media player (VideoLanClient) standardisierte Port. Über diesen Port kommuniziert sowohl der Cinerenderer als auch das beim Kunden installierte Programm ManyCamService.exe
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			Question:

How can manufacturer catalogue data be installed or updated retrospectively?



Answer:

To install or update manufacturer catalogue data, such as the reinforcement connections from ERICO-Lenton, at a later date, please proceed as follows:

Firstly, you need the latest installation package for your version
You can find this either on Allplan Connect (www.connect.allplan.com), or from our webdrive at

https://webdrive.allplan.com/s/4LrjrymoxESzC6p

The installation packages can be found under
Allplan/"Version"/Installation package

(Click on the three dots to the right of the file size and select Download)

Note: Do not download all files (that's about 450GB!), but only the installation package for the version you need.

Copy the zip file to your local computer.


1. please open your STD directory of the central file storage via the Allmenu of the Allplan version to be updated.

[image: ]



2. please close all running Allplan applications and the Allmenu in the company again

3. rename the Prod subdirectory in the STD directory you have just opened to Prod_old

4. now unpack the ZIP file of the version you have just downloaded in an empty directory and then start AllplanSetup.exe by double-clicking the left mouse button

[image: ]



5. please select "Update" when asked for the installation option

[image: ]


6. when asked for the licence to be used, simply select "Use active licence"
7. under "Setup type", now select the Customised variant

[image: ]


8. you can then first decide again on the languages to be installed

9. in the following window, you can select the manufacturers from which you would like to install the current catalogue data for the products. Please make your selection here.

[image: ]


10. then you will be asked for the country packages, which is usually easy to confirm.

11) Finally, you will see a small overview window in which you can start the update installation.

After successful installation, the current catalogue data should now be available when using the functions for the reinforcement connections and can be used without any further messages.


Hint: 
Ideally, have these instructions carried out by your IT service provider/administrator.
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			Question:

I can neither check in nor check out the computer.
When I try to check in the computer, the following error message appears: “The registry entries are not correct!” How can I correct this error?


Answer:

There is a hidden file on the server. This file causes the problem, which is probably related to user rights or user account control. 

You have to change the settings directly on the server, that is so say, you have to use the folder options to show all hidden folders and files. 

1. Open the central file storage folder on the server. There is a subordinate folder called 
NET. This folder contains the computer_name.out file. Here, computer_name is the name of the computer that is checked out.
Delete this file.

2. Open the shared folder (for example, C:\Nemdata\Allplan) on the computer that is checked out.
Allplan 2015 and earlier: Delete the Net.ChkOutfolder.
Allplan 2016 and later: Delete the NETfolder.

Now the computer is checked in again. Consequently, you can move projects to this computer 
or check it out once more. 


Note:

If the computer or the projects are still red, you have to fix the projects.

To fix the projects:
Services application -> Workgroup Manager -> Administer projects and computers

Do the following:

Ctrl + right-click computer-> can be checked in
Ctrl + right-click project-> can be unlocked

Repeat this step to unlock every project on the computer.
When you have finished, close the dialog box and open it again to update it.
Now everything should be correct.
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			Question:

How to update the license server and the licenses? 



Answer:

Allplan 2016:  Before you do anything, make sure Allplan 2016-1-4 or later is running on all clients.  
Allplan 2017 and higher: Check the version of the license server as described below and update the licenses. 

1. Updating the license server 
Check the version of your installed license server on the server. Starting with the license server version 2016-1-4, the detailed version status (Build-ID) is displayed directly in the lower left corner of the License Settings program.
The latest version 1.11xx.xxx.xxx should be displayed here. If an older Build ID is displayed, then you still have an older license server in use. In any case, please update your license server. Download the software for the license server from Allplan Connect - license server version 2021 or from the following link.

https://webdrive.allplan.com/index.php/s/4LrjrymoxESzC6p

The package is in the folder

/Allplan/Lizenzserver/2021/

Start the new License Server Setup on the server or computer you use as the license server. Right-click the *.exe file and select 'Run as administrator' on the shortcut menu.
	Click Install.
	Click Exit. 


If you have not yet installed the license server or if you have not switched to Allplan 2016 or higer until now, you can find detailed step-by-step instructions at
https://connect.allplan.com/en/faqid/20150618084450.html


2. Updating the licenses
Update the licenses at the license server as follows:

	Start the License Settingsprogram on the server.
	Click License activationon the left. Then click the license you want to update so that this license is highlighted in blue.
	As you can see, the 'Update license' function is now available.
	Click Update license.
	If your license includes configurations for several seats, you must update each license separately.



Note: When updating the license it can be that you will receive a higher version of the license as the version of Allplan you are using. The license is downward comatible and can be used until Allplan 2016.
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			Task: 

You want to transfer a project with all its settings to a partner office for further editing.

Note: 

The following description works only if both partners use the same version of Allplan (Allplan 2018-1 or later).

1. Backing up the project:

Before you back up the project, make sure that “office” or “project” is selected for the path settings of the project. 
To do this, open ProjectPilot and select the project: right mouse button -> Properties-> Settings. Here, you can select the path settings. 
For exchanging projects with partner offices, we recommend that you switch all project settings to “project”. 
This ensures that all pen definitions and line definitions, user-defined fonts, patterns and hatching styles, bar and mesh cross-section catalogs, and layer definitions will be copied to the project and backed up together with the project.

Note:
After the backup, switch the path settings back to “office”. But do not change the paths that already had the “project” setting.

Start Allplan and select the “File” menu -> “New Project, Open Project...”.
Right-click the project that you want to back up and select "Create project backup".
(Allplan 2018: Select “Compress and export project”: )
Select the folder where you want to save the project.

2. Importing the project:

To add a compressed project to the "New Project, Open Project" dialog box

Start Allplan and select the “File” menu -> “New Project, Open Project...”.

	Drag a compressed project (*.zip) from the desktop or from File Explorer into the "New Project, Open Project" dialog box.
	Specify the folder and enter a name for the project; then, click OK.
	Allplan unzips the project, adding it to the project list.





			
		

	




		
			








	
		
			
				
					
					Import: handling large coordinates, four options
				

				

			


			

				
					
						  Link
					
					

					
					

				

			

		

	


	

		
			
				
					Version: 
					Allplan 2017, Allplan 2021, Allplan 2020, Allplan 2019, Allplan 2018

				
				
				 | Last modified: 27.02.2024 13:56
				
			

			
				
						 

							
								
							

						 rate

						

					
			

		

		
			

			Question:

How can I import DXF and DWG files that contain elements with large coordinates?



Answer:

Imported DXF and DWG files that contain elements with large coordinates can cause performance problems in Allplan. To avoid problems with this data, you have the following options:
Option 1: set an offset
Set an offset in the project. In Allplan 2011 and later, you can do this directly when you create a new project.  For existing projects, you can specify offset coordinates later. To do this, select the File menu -> clickOpen Project-> select the relevant project -> open the shortcut menu and click Properties. (In Allplan 2009 and earlier, select the Tools menu -> Options -> Advanced Draft -> Settings tab). The offset can also be set automatically during the import, which is described in option 2.
Option 2: adjust center of gravity to: offset 
When importing, select the Options -> General Settings tab (Advanced Transfer Settings tab in V2008 and earlier) and select the Adjust center of gravity to "Offset" check box. The system automatically sets an offset in the project. Consequently, the origin of the file (= center of the min-max-box) is set to the origin of the coordinate system. This option is not available if you have already specified an offset or if the data to be imported does not contain large coordinates.
Option 3: adjust center of gravity to: origin
When importing, select the Options -> General Settings tab (Advanced Transfer Settings tab in V2008 and earlier) and select the Adjust center of gravity to "Origin" check box.This moves the center of the file to the origin of Allplan’s coordinate system. As opposed to the previous option, the coordinates themselves are changed. Use this option only when you do not need to export the data again.
Option 4: adjust center of gravity to: off
This imports the data into Allplan; the coordinates are not taken into account. To optimize working with large coordinates, select the Options -> Desktop environment page ->  Optimize working with large coordinates (in Allplan 2009 and earlier: Tools menu -> Options -> Global Options -> 'Miscellaneous' tab -> Optimize working with large coordinates). However, the larger the volume of data you create far from the origin, the slower the performance might get. In addition, you can can move the data to the origin using Allplan's "Move" tool and, if necessary, specify a corresponding offset later.



Note: 
Using an offset (as described in the first two options) is usually the better solution. You edit the data at the origin of the coordinate system but - due to the offset specified - point coordinates are measured correctly. The offset set is automatically taken into account when you export and import data, and it applies to the entire project. 
If you do not need to export the data with the same coordinates again, we recommend that you use option 3 - adjust center of gravity to: origin.
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			Question:
Internet connection exists on your computer and the settings used for the proxy for the URLs you have set also. You try to activate your license with your product key, but the activation could not be performed. You get the message ' server not found error'. How can the license be activated yet?

Reply:

License activation:
The following description is valid for single user license as also license server licenses.
Try to activate the licenses on the computer/server via the following website online. 
This Web site must be launched directly on the computer on which the license should be enabled.

http://lc.codemeter.com/59885/depot/index.php

In the row "Ticket", enter your Product Key and click continue your license will be displayed, click on activate license now.

Note: (only for license server license)
A selection appears asking for the binding of licenses.
Select firm code 6000100 on the right hand side.
'I want my licenses on one computer (CmActLicense). Firm code: 6000100 CmContainer ALLPLAN CM6 (2000)'
 
Sometimes multiple rows for the same license will be displayed (E.g. license number and a -u behind it) please leave all licenses checked and click on Activate selected licenses now.
The transfer of the license starts now. When activation is finished your license on this page should now appear with status activated.

If the problems with license activation occurred during the installation of ALLPLAN, cancel to exit Setup and restart the installation of ALLPLAN again. Then select in the Setup license configuration use active license now and the installation can continue.

Then open the license setting over services -> utilities-> license settings.
Or license server via License Settings.
Click on the left side on license selection. Now the license is displayed under the computer name.

License return:
This Web site must be launched directly on the computer on which the license should be enabled.

http://lc.codemeter.com/59885/depot/index.php
In the row "Ticket", enter your Product Key and click continue your license will be displayed, click on re-host license now.
Sometimes multiple rows for the same license will be displayed (E.g. license number and a -u behind it) please leave all licenses checked and click on Re-host selected licenses now.
The transfer of the license starts now.

Notes:
	Sometimes the license is not displayed under license activation, because it has been enabled via the website.
	If you want to remove the licenses, you must do so via the website again.
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Question:

The icons and descriptions in Allplan are too small, too big, or blurry, how can you change that? How can Allplan be operated with a QHD/UHD/4K resolution?



Answer:

From Allplan 2023, the setting will be adopted from the Windows display setting so that Allplan adapts correctly to the high-resolution screens.
For this to work properly, it is crucial that the QHD/UHD/4K screen is defined as the main screen.

Background: Allplan always starts automatically on the defined main screen, so it is important that this is correctly defined and scaled so that the display in Allplan is correct.
 

Check/set the following settings:



1. To ensure that changes to the settings are applied correctly, first close Allplan

2. Go to Windows Settings. Start -> Settings -> System and select Screen. Or right-click on the desktop and select Display Settings.

Windows 10: Click Identify, then click your QHD/UHD/4K screen in the display so that it turns blue.
In the area below under the Multiple Screens section, select 'Expand this display' and apply the setting. Then check the box for 'Use this display as main display'.


Windows 11: At the top under the screen display, select 'Expand this display' and apply the setting. Click Identify, then click your QHD/UHD/4K screen in the display so that it turns blue. As the first entry under Multiple screens, tick 'Use this display as main display'.

Here is an example for Windows 11

[image: 20-03-_2023_13-53-40.png]


 

Leave the scaling and resolution at the recommended values.

3. Start Allplan and test the view. You may need to increase the scaling a little, depending on how big you want the icons etc. to be. To do this, exit Allplan again and increase the scaling, for example to 125% or 150%, and then start Allplan again.

 
Hints:
- If Allplan is dragged from the QHD/UHD/4K screen to the smaller or non-high-resolution screen, the icons in Allplan are all larger.
- if the smaller, non-high-resolution screen is the main screen, then everything in Allplan is displayed too small.
- If the display in Allplan is blurry, then it is probably because the screen was not expanded but was duplicated. Then the resolution of the smaller, non-high-resolution screen applies and the display in Allplan is blurry. QHD/UHD/4K cannot then work because the settings are adopted from the smaller, non-high-resolution screen and only transferred to the larger screen.
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			Question:

Does Allplan create backup files (*.bak)?
How can I use these files?



Answer:

Allplan creates backup files when you do the following:

	Copy, Move Elements between Documents …
Allplan creates a backup file of the destination drawing file or layout.
	
	Deleting drawing files and layoutsin the "Open on a project-specific basis" dialog box
If you have selected "Create backup copies of drawing files", Allplan creates a backup file of the drawing file or layout.
	
	Importing data to drawing files
If you have selected "Create backup copies of drawing files", Allplan creates a backup file of the drawing file.


Note on points 2 and 3: 

To select the "Create backup copies of drawing files" option, click
Tools -> Options -> Desktop environment -> Save/load area (until V2009 Global Options -> Miscellaneous -> Autosave, Backup)->Create backup copies of drawing files.


Restoring:

If need be, you can restore the original drawing file or layout.
Make a note of the drawing file number or layout number and determine the corresponding project folder as follows:
Services application -> Service -> Hotline Tools -> wopro

Open this folder in Windows Explorer.

Rename the corresponding drawing file "tb000001.ndw"  "tb000001.ndw.old" or the corresponding layout "pb000001.000" "pb000001.000.old.", for example.
Delete the bak extension from the corresponding bak file.

Example 1: 

You have inadvertently copied the wrong elements to drawing file 4711.
1st step: exit the project in Allplan.
2nd step: delete file tb004711.ndw or rename it tb004711.ndw.old.
3rd step: find file tb004711.ndw.bak and rename it tb004711.ndw.

Example 2: 

You have inadvertently copied the wrong elements to layout 815.
1st step: exit the project in Allplan.
2nd step: delete file pb000815.000 or rename it pb000815.000.old.
3rd step: find file pb000815.000.bak and rename it pb000815.000.



Note:

These backup files can considerably increase the volume of data to be backed up. So it is a good idea to delete the .bak files you no longer require before you start backing up data. To delete the .bak files, you can select the Services application and click Utilities -> Delete temporary files.

You can also find this information in the help for Allplan. Please refer to the topic "Using bak files".
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			Task: 

You have installed Allplan on several local workstations. Now you want to change the installation so that you can access a common network drive.



Note: 

Before you switch to a network installation, it is essential that you back up all the data of all the workstations. 
We strongly recommend that you take advantage of the expertise of Nemetschek’s technical support staff. We are happy to help you!



Solution: 

The following description shows how to change several workstations where Allplan is installed locally and the project data is also stored locally on each computer to workstations with a common network drive without Workgroup Manager.

1st - getting ready
Choose one of the workstations where you will install all the projects and the office standard (hereinafter referred to as the main workstation). 
First, move all the projects to the main workstation.

1.a: copying resources into projects
To make sure that the projects in your office have a uniform appearance, change the path settings for the projects' resources to 'Project'.
Make the following setting for each project:
Allplan -> File menu -> ProjectPilot - Admin -> select the individual projects one after the other -> right mouse button -> Properties -> Settings tab
Set the path settings for 'Pen and line definitions', 'Fonts', 'Patterns, hatching styles, area styles', 'Bar and mesh cross-section catalogs', 'Layer structures, line styles, drawing types' and 'Attributes proposed' from 'Office' to 'Project', if necessary.
The corresponding elements are copied from the office standard directly to the project. This ensures that the project settings stay the same even when you copy the project to the new server with the new office standard.

1.b: same folder name as project name
Open the 'General' tab and select the 'Same folder name as project name' setting if you want to proceed as described in 2b.

1.c: pen color ("Color stands for pen")
The pen color for the "Color stands for pen" setting is a user-specific setting that is not saved in the project but in the user folder (...\Usr).

2.a: backing up projects of the individual workstations and importing them to the main workstation (recommended method):
Back up the individual projects. To do this, open the Services application and select  Data Backup -> Create -> Entire folders -> Projects. 
You can back up several projects in a single operation.
Before you start, specify the backup folder on the network or on the local hard disk: Services application -> Configuration -> Backup path ->Browse for Folder.

The next step is to import the saved projects to the main workstation.To do this, open theServices application -> Data Backup -> Import -> Projects Before you import the individual projects, you can create new Allplan projects at the main computer. As an alternative, you can also create a new project during the import.

2.b: backing up projects of the individual workstations and importing them to the main workstation (special approach):
This approach should only be used with good reason for exceptional cases as it requires in-depth knowledge of Windows. 
With this method, Windows Explorer is used to import the projects to the main workstation.
If some project names exist twice, you need to rename these projects before you back them up.

You can then rename the existing 'project.dat' file in the Prj folder of the main workstation.
Next, select the Services application -> Service -> Hotline Tools -> reorg -> Restore project management file.
The system creates a new project administration file (project.dat), which should list all projects with names.

Now the main workstation contains the latest version of all the projects of the office.

3rd -  merging project defaults
Open ProjectPilot at the individual workstations and copy the elements you want to transfer (symbols, smart symbols, lists, schedules, and so on) to the external path. Of course, you can set the external path to a common network folder that can be accessed by all workstations.
Next, open ProjectPilot at the main workstation and copy the contents of the external path to the office standard.

4th -  data backup
	Back up the projects, office standard and user settings at the main workstation:
You can also copy the ..\prj (projects), ..\std (office standard) and ..\usr (user folder) paths to a backup folder (Nemsic, for example) on the hard disk.
	In addition, you need to back up the ..\usr\local folder at every stand-alone computer.
	Export the user interface setting of each user to a file: Allplan -> Tools - > Customize .... -> Export...


5th -  uninstalling
Remove Allplan from all workstations.

6th -  reinstalling
Before you install the same version again, create and share a folder (Nemdata, for example) on the future data server. Create a subfolder - Allplan - in this folder.

The next step is to reinstall the same version on all the workstations.

Specify the following installation paths:
Program folder:    
local (C:\Programs\Nemetschek\Allplan, for example)
Central file storage folder: 
Browse -> Network...
Find the sharedNemdata folder and select the Allplan folder. 

After this, start installing.

7th -  testing the start and restoring the backup
After the installation (check whether Allplan starts), copy the ..\prj and ..\std folders you backed up from the main workstation to the new  ...\Nemdata\Allplan server folder. 

Next, use Windows Explorer to copy the contents of the former user folder (…\usr\local) of the stand-alone workstation to the new user folder of the computer you just installed.

8th -  updating the project administration file
Go to the project.datfile in the ...\Nemdata\Allplan\Prjfolder and rename itproject.alt.After this, do the following:
Services application -> Service -> Hotline Tools -> reorg -> Restore project management file. 

9th -  summary
Now all the workstations access a common network drive with the same project pool and office standard.
With this type of installation, only one user can access a project at any one time. If several users are to work on a project at the same time, you need to install Workgroup Manager.



			
		

	




		
			








	
		
			
				
					
					Allplan silent installation (Allplan 2017 and later)
				

				

			


			

				
					
						  Link
					
					

					
					

				

			

		

	


	

		
			
				
					Version: 
					Allplan 2020, Allplan 2019, Allplan 2018, Allplan 2017, Allplan 2021

				
				
				 | Last modified: 28.02.2024 08:37
				
			

			
				
						 

							
								
							

						 rate

						

					
			

		

		
			

			Question:

Can I "automate" the installation of Allplan?


Answer:

You can install Allplan 2017 in silent mode. This installation mode is fully automatic; you do not need to enter anything. Silent installation is particularly useful if you want to install Allplan 2017 with the same settings on a large number of workstations on a network.
Requirements for installing in silent mode:
Pay attention to the different licensing types!
Licensing for stand-alone workstations: 
Make sure you have not yet activated a license on the computer where you want to record silent installation. Use the Viewer option for recording. 

After having installed all computers in silent mode, you must use the Product Key to activate the license locally on each computer. 
To activate the license after installation:
	Open the 'License settings' dialog box: Services application -> Utilities -> License settings
	Click License activationon the left.
	Enter your Product Key.
	Click Activate license.



Using a license server:
	The clients take the licenses from a license server. 
	The license server is installed. 
	The license of the license server is activated.

For more information on the license server, go to http://connect.allplan.com/de/support/loesungen.html?tx_nemsolution_pi1%5BdokID%5D=20161115093205.htmlhttps://connect.allplan.com/en/faqid/20150618084450.html[image: ]

Use the Use active licenseoption for recording.

Setup writes the license settings to the %AppData%\Nemetschek\Lic3.ini file.You must distribute this file to all computers.


Some more tips:
	Before you start installing, unzip the Allplan installation package (for example, using the 7_Zip program). Make sure this package is in a folder that can be accessed by all clients you want to install.
	Start the command prompt for running the setup program always as a local administrator. To do this, open the shortcut menu and select "Run as administrator". Make sure you always start the command prompt from the correct folder.
	Setup will automatically install any Microsoft components required by Allplan such as Microsoft .NET-Framework or Microsoft Report Viewer without prompting you to confirm.




Preparing to install in silent mode

To record and run silent installation, you need the installation files of Allplan 2017.
Installing in silent mode involves three steps:
Creating the log file for installing in silent mode
Start by installing Allplan 2017 with the /r option on a typical workstation. During installation, Setup automatically writes all entries to a log file named setup.iss. You can then use this file to install the program on the other workstations.
Installing in silent mode
Next, install Allplan 2017 with the /s option on all other workstations. Installation is based on the setup.iss log file you created in the first step.
Checking the installation
Finally, you should check the setup.log file, which was created automatically during setup, to see whether everything was installed correctly.
Note: When installing in silent mode, Setup usually uses the same setup.iss file to install the program on all workstations. However, you can edit some settings of the setup.iss file if you want to adjust paths. You can find more information in the help; see Adjusting the setup.iss filehttp://help.allplan.com/Allplan/2017-0/1031/Allplan/index.htm#331.htm


To install Allplan in silent mode, do the following:

Install .NET 4.6
Silent setup requires you to install .NET 4.6 in advance. The reason for this is that you have to reboot the computer after installation of .NET 4.6. This reboot would interrupt silent installation.


After you have downloaded the installation files, you must unzip these files before you can use them to install in silent mode.
	Unzip the zip file downloaded. This results in an .exe file (for example, Allplan 2017-0-5-cad.exe).
	Then unzip this .exe file using an appropriate program (for example, 7_Zip) and save the resulting file to any folder. You can now use the command prompt to start Setup.exe for recording.



1. Sample installation:
Start by creating a record file. To do this, run setup with the settings you need. You only need to do this once.

Use the command prompt to start this installation with the "/r" option (for record):

To run the setup program, open the command prompt as a local administrator and type the following: 
setup.exe /r 

Setup starts and runs as usual.

Stand-alone license:
When you are prompted to choose the license configuration, select the Use vieweroption.
License server:
When you are prompted to choose the license configuration, select the Use active licenseoption.


Setup logs the entire installation process, writing everything to the setup.iss file.

If you want, you can change the name and folder of this file:

setup.exe /r /f1<folder>:\Setup.iss
For example,
setup.exe /r /f1c:\Setup.iss
This saves the file directly to C:\.

Be careful: 
There must not be any blanks between "f1" and the folder!

Copy the setup.iss file to a folder that can be accessed by all clients you want to install. It is a good idea to copy this file to the folder with the Allplan installation files. 

License server:
Copy the %AppData%\Nemetschek\Lic3.inifile to the %AppData%\Nemetschek folder of every client.
If you install Allplan on a client for the first time, you must create the Nemetschek folder in %AppData% first (for example, C:\Users\Username\Appdata\Roaming\Nemetschek). 


2. Silent installation:
Make sure you can access the setup.iss file.

License server:
Make sure the Lic3.ini file is in the %AppData%\Nemetschek\ folder.


Setup logs the entire installation process again, writing everything to the setup.log file. You can find this file in the same folder as the setup.iss file. With the /f2 option, you can specify a different folder and file name for the setup.log file.

To start installing Allplan in silent mode on a client, open command prompt as a local administrator and type the following:

setup.exe /s /f1<folder>:\Setup.iss /f2<folder>:\Setup.log

For example,
setup.exe /s /f1c:\Setup.iss /f2c:\Setup.log
This saves the file directly to C:\.

Check the setup.log file to see whether everything has been installed correctly. The [ResponseResult] section should return the 'ResultCode=0' value.



Note: 

If you have several licenses or license servers, select the required license for each client using the Services application - Utilities - License settings.

Refer to the online help for detailed information on installing in silent mode. 
http://help.allplan.com/Allplan/2017-0/1031/Allplan/index.htm#321.htm
To open the help system, press the F1 key during setup. Go to the "Contents" tab, select "Installing" and then "Installing in silent mode".

You can also find information in the help for the license settings:
Services application -> Utilities -> License settings 
To open the help system, press the F1 key. Go to the "Contents" tab, select "Licensing Allplan using a license server" and then "Installing in silent mode".


Please note that we cannot provide support for this installation method.
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			Question:

You would like to know which colleague has borrowed a license from the license server and for what period of time it was borrowed?


Answer:

Prerequisite:   
Please make sure that at least Codemeter version 6.60b is installed on the license server.
To do so, start the CodeMeter Control Center on the server
Either in the Windows Start menu via CodeMeter -> CodeMeter Control Center. Or enter Codemeter in the search bar of the start page and press ENTER. Under Help-> About you can see the installed Codemeter version. If a version lower than 6.60b appears here, install the latest version of the Control Center released by Allplan. Instructions on how to do this can be found at the following link https://connect.allplan.com/de/faqid/20160113131406.html


Application:
The administration of the license server is done via the CodeMeter WebAdmin application on the server itself.
Start the CodeMeter Control Center at the license server on the server
Either in the Windows Start menu via CodeMeter -> CodeMeter Control Center. Or in the search bar of the start page enter Codemeter 
and press ENTER, then click WebAdmin in the dialog box at the bottom right.

Or:
Type Localhost:22350 in the address bar of your browser.

In WebAdmin go to Container -> All Containers -> here select your Allplan Cm6 in which your license/s have been stored -> select the desired license by clicking on the Product Code 999 in front of it. -> Now scroll down to the end, to the License Transfer History area.

Here you can see exactly when the license was borrowed, for how long and by which user.
[image: ]


Hints:
If you want to see which users are currently in the network pulling licenses from the license server, you can also see this. To do this, go to License Monitor-> Sessions in WebAdmin.

Borrowed licenses are currently only displayed with the container number under License Monitor-> Sessions, only under License Transfer History the user is also visible.

Since under License Transfer History it is a complete history, all license loans are listed, even those that have already been terminated, i.e. the license has been returned to the license server in the meantime.
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			Question:

How can Allplan program data be repaired?



Answer:

The Allplan program files can be repaired via a repair installation.

To repair the Allplan program data, please proceed as described:
In Windows, select Start [image: ]
 > Einstellungen > Apps > Apps  and Features. 

Select the Allplan version (from Allplan 2022) for which you want to repair.
Select the "Change" button offered in the dialog that now appears. 

[image: ]


The Allplan Setup Menu is started. 
Select the "Repair" option here

[image: ]


You can then select the components to be included in a repair installation in the options of the Allplan installation dialog. 
To perform the repair installation, select the "Install" button.

[image: ]

The repair installation will now be executed.
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			Question:

How can I import a DWG/DXF file into Allplan?



Answer:

A DWG/DXF file always consists of the model space (design). In addition, the file can have one or more layouts (paper space). AutoCAD’s paper space is similar to the layout editor in Allplan; AutoCAD’s model space is equivalent to drawing file edit mode in Allplan (provided you work with only one drawing file).

You can use the following settings for import:

Import to a drawing file
For importing only the model space of the DWG file
Double-click an empty drawing file to select it. Then click File -> Import -> Import AutoCAD Data... -> Settings(click the icon showing the gearwheel).
Click Resetat bottom left to restore the default settings. 
If you do not require 3D data, open the 'General Settings'tab and select 2D for the transfer mode. Open the 'AutoCAD specific' tab and select the 'Design (model space)' and'Check file during import' options.
Click OKto confirm the settings. Then click Opento start importing the data.

Another dialog box appears. Click the Modifybutton.You can then check and correct the assigned colors, line definitions, layers and so on. To do this, select the entry you want to change and reassign it using the shortcut menu (right mouse button)

Import to a layout
If the DWG file has one ore more layouts you want to include in the import.
Select an empty layout. Then click File -> Import -> Import AutoCAD Data... -> Settings(click the icon showing the gearwheel). Click Resetat bottom left to restore the default settings.
If the DWG file has several layouts, you can open the 'AutoCAD specific' tab and select the 'Multilayout' option. You can then select the layouts you want to import. In addition, select the 'Check file during import' option.
Sometimes the unit used in the layout can differ from that used in the design. In this case, open the layout editor and set the unit from 'm' to 'mm'. Then open the 'AutoCAD' tab and set the Factor for correcting layout unitto 1000(1000 mm = 1 m).
Another dialog box appears. Click the Modifybutton and open the 'XRef files'tab. Select the entry. Open the shortcut menu and assign an empty drawing file.  Allplan will create the design of the DWG file in this drawing file.


Note: 

If you still cannot import the DWG file, please send this file by email to support.de@Allplan.com. 
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			Question:

I installed Allplan with Workgroup Manager on a new computer for the first time. When I start Allplan, I get the following message: The user profile "DOMAIN\user name" was not found. Temporarily, the profile of local will be used. 
Therefore, I cannot access any project. What can I do?



Answer:

You have logged in to the computer with a new Windows user who does not yet exist in Workgroup Manager administration of Allplan. 
You need to add this new user to Workgroup Manager. To do this, log in as the administrator to the computer or use a different computer where a user has administrator privileges for Workgroup Manager.

Services application -> Workgroup Manager -> Administrate users -> right-click -> Create user

For the "user name", you can enter any Allplan user name, which can be up to 8 characters long.
For the "Windows user name", you must enter the name the user uses for login. 
Important: If the user uses a domain for login, you must add it to the "Windows user name", for example, DOMAIN\user.


There is one Allplan administrator and any number of normal Allplan users.
A Windows user with any login name becomes an Allplan administrator if you go to "User group" and
select "Administrator"on the dropdown menu. Using this approach, you can also assign administration privileges to existing users.


You must enter the email address and the password only if the user is notpart of the workgroup but needs access to online projects (Workgroup Online). 


Important: Click "Apply" and then "OK" to close the dialog box and the user overview respectively.



Note:

After you have created the user as an Allplan user, do not forget to assign the relevant projects to this user. Otherwise, this user is not allowed to edit the projects.
To find out how to
make several projects available to users: https://connect.allplan.com/en/faqid/0001cbd2.html
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			Question: 

I have installed Allplan using the temporary Softlock license ("customer#_seat_psd.nslock") and "Trial" is displayed for its status in the License Manager.
How can I register this license?



Answer: 

You use License Manager to create a registration request and send it by email to register@nemetschek.de.
In response, you get a final license file. Installing this license removes the lime limit.
Below is a description of the necessary steps.



Notes: 

	Using the temporary license, you can start Allplan as a trial version. You can work with Allplan without any restrictions for 30 days.
After expiration of this period, Allplan starts as a viewer only. However, you can still request and install the final license.

	When running Windows Vista, start Nemetschek License Manager as the administrator: 
Start -> (All) Programs -> Nemetschek -> Nemetschek SoftLock 2006 -> License Manager 
Click "License Manager" with the right mouse button and choose "Run as administrator" on the shortcut menu.




How to proceed:

1. Request a license registered for your computer 

	On the Windows taskbar, click Start - (All) Programs - Nemetschek - Nemetschek Softlock 2006 - License Manager(or Services application -> Utilities -> License -> License Manager (NemSLock)).

When running Windows Vista, start License Manager as the system administrator: click Start - (All) Programs - Nemetschek - Nemetschek Softlock 2006 - License Manager. 
Click License Managerwith the right mouse button. On the shortcut menu, click Run as administrator. 

	Select the seat you want to register so that it is highlighted in blue.

Note:You can only register seats you have purchased. If you can see only seats with numbers between 90 and 99 (= trial licenses for temporary use), you first need to install the personal license for temporary use.

	Click License requestat top left. 

The License Request Wizardstarts. The Welcome to the license request wizarddialog box provides information on the steps that follow. 

	Click Next >. 
The Customer detailsdialog box opens.

Note: Editing customer details requires administrator privileges. If you do not have these privileges, you will see a corresponding message. Cancel NemSLock License Manager and start again by selecting the Run as administrator option on the shortcut menu.

	Enter the necessary details: 

- If the Client IDhas eight zeros (00000000) and the CD Keyhas eight capital F's (FFFFFFFF),  you selected the Trial license for temporary useoption when you installed Allplan. 
In this case, install the personal license for temporary use before you create the registration request.

- If Client IDand CD Keydo not match the numbers printed on your delivery note (for example, typing errors, small letters and capital letters mixed up), you can enter Client ID and CD Key manually. 

- Fill out all the fields. 

Make sure you enter your email address correctly, because registered licenses and replies to status queries of license will be sent to the address you specify here. 

Note:Check the entries for Client ID(customer number) and CD Key , making sure these numbers are the same as those printed on the delivery note you received from Allplan. The CD Keyusually consists of the numbers 0 to 9 and the capital letters A to F.

Tip: You can also find these numbers in the personal license file for temporary use (*_psd.nslock). Open the license file in an editor and scroll down to the end of the file. You can then copy the license codes displayed after CUSTOMERand CDKEYto the Clipboard and paste them into the appropriate boxes.

	Click Next >. 

	Select the Program, Versionand Seatand click Next >. 

Note: If the Client IDis invalid (for example, when you use a trial license) you cannot confirm the dialog box by clicking OK. Instead, you will see a corresponding message.

	Specify how to send the registration file and click Next >. 

Start email program ... 
The program creates and saves the register.txt file before it opens your default email program. The program automatically attaches the registration file to the email and enters register (please no spam) @ (please no spam) nemetschek.defor the address. 

Save the registration file ... 
The program creates and saves the register.txt file before it opens the folder with the registration file in Windows Explorer. Now you can use all the options provided by Windows Explorer: for example, you can attach the file to an email, copy it to a computer with Internet access and so on. 

In addition, you can see the data that were written to the registration file.

	Click Finish. 

	Click Close to exit NemSLock License Manager.


You will receive a reply by email within a few minutes. This email provides information on the registration process and usually includes the registered license file.

Note: The registered license file is generated by an automated system. Consequently, any additional comments in incoming emails are not read. If you have any questions or need more information, please contact Allplan directly.



2. Install the license file

Shortly after you sent the registration request to 'register@nemetschek.de' as described in step 1, the final license file will be sent to the email address you specified in the registration request.
Install this license file as follows:

	Save the license file to any folder on the hard disk.
If the license comes as a zip file, extract it.

	Next, install the license file by double-clicking it ("customer#_seat.nslock").
Confirm the dialog box.

	As an alternative, you can also use License Manager to install the license file (Start -> (All) Programs -> Nemetschek -> Nemetschek SoftLock 2006 -> License Manager).
Click "Install - Install license" at top left in Nemetschek SoftLock License Manager and select the license by clicking "Browse...".
Click "Finish" to complete the installation process.


Note:

Do not use the same computer to register several license files for different seats. This would connect the seats. You cannot separate the seats again without the help of technical support.
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			Question:

Whenever I try to create a project, the New Project, Open Projectdialog box does not open.
If I try to open ProjectPilot, the following message appears:Unable to create ProjectPilot control.What can I do?



Answer:

Some important entries are not defined in the Windows Registry. 

Close Allplan and do the following:

Services application -> Service -> Windows Explorer -> CAD program folder -> PRG

Find the NemProjectPilot10.exefile and start it as the administrator. To do this, right-click this file -> Run as administrator.
Start Allplan and open ProjectPilot by clicking File -> ProjectPilot. Then create a new project.
After this, open New Project, Open Project. This should work without problems.



Note: 

You require administrator privileges to write to the registry.
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			Question:

How can I change the company logo and address details for all reports?



Answer:

After having created a report, you can adjust the address and logo in the parameters. However, these settings only apply to the current report and they are not saved.

To adjust the defaults and thus to change the settings for all reports, select Tools -> Defaults -> Office Name and Addressin Allplan.
Enter the required information and select a bitmap file for the logo.

Now these defaults are used for each report you create. You can still adjust them in the report viewer after you have created the report.



Note: 

If you are working in a workgroup environment, only users with administrator privileges can change these defaults.
The information you enter for the office name and address, lines 1 and 2, is displayed both in reports and in lists.
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			Question: 

How can I transfer the NemSLock license permanently to a new computer?



Answer: 

Proceed as follows:

	Install the program on the new computer. Use the temporary license (xxx_xxx_psd.nslock) you received when you purchased the program. If you do not have a temporary license of the current version, contact your support team to request such a license.
You can then work with the program for 30 days – plenty of time to configure your new computer, transfer the office standard and projects and so on (you can find instructions in the FAQ database).
At the same time you can work with the program on your old computer without any restrictions.

	When you have transferred everything you need, return the license to us. To do this, use the old computer and click
Start -> (All) Programs -> Nemetschek -> Nemetschek SoftLock 2006 -> License Manager
(Services application -> Utilities -> License -> License Manager (NemSLock)).

Click "Relocate licenses -> Transfer licenses permanently to a computer". This creates the COMPUTER_NAME.hrdwchg file. Send this file by email to register@nemetschek.de. 


Tip: Click 'Browse' in the 'Send hardware change file (*.hrdwchg)' dialog box. The program creates and saves the COMPUTERNAME.hrdwchgfile. Then Windows Explorerstarts and the folder with the hardware change file opens. You can now use all the options provided by Windows Explorer: for example, you can attach the file to an email, copy it to a computer having Internet access and so on. Email this file to register@nemetschek.de.

Note:
After you have created this file, the Allplan license of your old computer will still be valid for two more days.
As soon as we have removed the registration, we will send you a confirmation by email. 

	Create a registration request (register.txt) on the new computer and send this file by email to register@nemetschek.de.

To generate a registration request, do the following:
Open the License Manager (Service application -> Utilities- > License -> License Manager). Select the license entry for your seat and click "Request license". Please follow the instructions displayed on screen. Complete the form. Do not forget to enter your email address. 

You will promptly receive the license for the new computer (provided you have returned the license to us as described above). 
Installing this license file completes the license transfer to the new computer.



Note:

The COMPUTER_NAME.hrdwchg file is stored in the following folder:

Allplan 2012 and earlier:
	Windows 64-bit:

C:\Program Files (x86)\Common Files\Nemetschek\NemSLock2006\License
	Windows 32-bit:
C:\Program Files\Common Files\Nemetschek\NemSLock2006\License



Allplan 2013 and later:
	C:\ProgramData\Nemetschek\NemSLock\AllplanLicense
	or C:\ProgramData\Nemetschek\NemSLock\HardwareTausch







			
		

	




		
			








	
		
			
				
					
					First steps - activating the license using the Product Key
				

				

			


			

				
					
						  Link
					
					

					
					

				

			

		

	


	

		
			
				
					Version: 
					Allplan 2022, Allplan 2023, Allplan 2024

				
				
				 | Last modified: 27.02.2024 13:54
				
			

			
				
						 

							
								
							

						 rate

						

					
			

		

		
			

			Question:

I would like to install Allplan, and I have a Product Key. How can I install Allplan and activate the Product Key?


Answer:

Allplan licensing is based on CodeMeter by Wibu Systems AG.

 

Allplan requires a Product Key. Using this key, you can activate your license online. The Product Key is a unique, 26-digit character string. You can use it to activate a license for Allplan.
You can find your Product Key in Allplan Connect. Go to http://connect.allplan.com/license
Note: The license is downwards compatible til version Allplan 2016 even if a higher version is displayed.

 

Your license for Allplan is activated after installation, when you start Allplan for the first time. The license is activated online. You can either start Allplan directly here or close the license window. Activating the license links it to your computer and allows you to start Allplan on this computer.

Activating the license works easiest and fastest if the computer on which the license is to be activated has Internet access.

 


Activating the license during Allplan startup
	Start Allplan
	The 'License settings' dialog box appears first.
	Click on License Activation on the left.
	Enter your product key.
	Click Activate license
	After successful activation, click Start Allplan at the bottom.



Activate license in advance via the Allmenu/Services:
	Call up the 'License Settings' dialog box via Allmenu/Services -> Utilities -> License Settings.
	Click on License Activation on the left.
	Enter your product key.
	Click Activate License.


Notes:

You can find your Product Key in Allplan Connect. Go to http://connect.allplan.com/license
Click Profile -> License administration.
Only administrators can use this function.
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			Question:

Why does ProjectPilot open with the following error message:
"Unable to create ProjectPilot control. Is the registry correct?"



Answer:

The reason for this is usually an "external path" that no longer exists. When you start ProjectPilot,
the program tries to access the "external path", which is stored in the Windows Registry.
If this path no longer exists, you will see the above error message.

To correct this error, please do the following:

	Services application
	Service menu
	Windows Explorer - CAD program folder
	The path to the "User folder" is displayed in the window of the Services application. Open it in Windows Explorer.
	Find the "extern.cfg"file in this user folder and delete this file.



Now try to start ProjectPilotagain. If the problem still occurs, please do the following:

Start the services application -> Service -> Windows Explorer -> CAD program folder. 
Open the "PRG" folder.
Find the following file: "NemProjectPilot10.exe"
Right-click this file -> select "Run as administrator" on the shortcut menu.
ProjectPilot should now start. 

Try to start ProjectPilotstraight from Allplan. If the problem is still not solved, please do the following:

	Services application
	Service menu
	Windows Explorer - CAD program folder
	The Allplan program folder opens.
	Rename the "PRG" subfolder "PRG_OLD".
	Start installing the program from the current Allplan DVD.
	Select "Update installation".
	Select "Current license file".
	Set the setup type to "Minimum".



After installation try to start ProjectPilotagain.
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			Question:
I purchased a new license and received a Product Key for Allplan. However, I work with an earlier Allplan version. How can I install and license Allplan 2015 or an earlier version despite the new license? 


Answer:

Allplan 2016 introduced a new protection system. Since then licensing has been based on CodeMeter by Wibu Systems AG. You can no longer use Softlock (NemSLock) or hardlocks with Allplan. For running Allplan, you get a Product Key by email. Using this key, you can activate your license online.

This new license is not downward compatible. Consequently, you cannot use it for earlier Allplan versions.

For licensing earlier versions, you require the Client ID and CD Key. You can find this information in the delivery note or invoice. Instead of a temporary license, use the appropriate trial license to install Allplan 2015 or an earlier version. Then generate a registration request to license and activate the modules you purchased.

Note:
If you use a license server for which you purchased an additional license, please read the separate document or contact support.de@allplan.com. We will show you how to add the new license to the license server.  

If you want to install Allplan 2015 or an earlier version, use a trial license to install the version you need.

Downloading Allplan:
Make sure the Allplan version you install is always up-to-date. In other words, it should include the latest hotfixes and service releases.
You can download the current Allplan version from Allplan Connect or the FTP server. 
Allplan Connect:
https://connect.allplan.com/de/support/downloads.html


1. Install Allplan with a trial license 
Install Allplan. In the 'Select License Information' dialog box, choose 'Trial license for temporary use' and select the license for 'Architecture' or 'Engineering'. 

Important: If you work with Workgroup Manager, select 'Different trial license' -> 'Next'. Open the Workgroup folder for your country and select the appropriate license. Then follow the instructions and install Allplan. Make sure you enter the paths correctly.


2. Request a license registered for your computer 
The trial license is valid for 30 days. It is not personalized.
Consequently, you have to enter your personal data manually when generating the registration request. 
You can find the required Client ID and CD Key in the delivery note or invoice.

To generate a registration request, do the following:

Open the License Manager (Service application -> Utilities- > License -> License Manager). 
Select the license entry for your seat and click 'Request license'. Please follow the instructions displayed on screen. 

Note: Editing customer details requires administrator privileges. The system will issue an appropriate message. Close NemSLock License Manager and start the Services application again. To do this, click the Services desktop icon with the right mouse button and select 'Run as administrator' on the shortcut menu.


Enter the necessary details: 
The Client IDhas eight zeros (00000000) and the CD Keyhas eight capital F's (FFFFFFFF). 

For the Client ID, enter your customer number. You can find your customer number in the letteror delivery notethat came with Allplan.
For the CD Key, enter your CD Key, which you can also find in the letter or delivery note. Make sure you use small letters and capital letters accordingly.

Note:You can find the Client ID and CD Key at top left in the delivery note. The CD Keyusually consists of the numbers 0 to 9 and the capital letters A to F.


Fill out all the fields. Make sure you enter your email address correctly, because registered licenses and replies to status queries of license will be sent to the address you specify here. 
Click Next >

For the seat, change the number 94 to the license you purchased, for example, 02, 03 or 04.
Specify how to send the registration file and click Next >. 

Start email program ... 
The program creates and saves the register.txt file before it opens your default email program. The program automatically attaches the registration file to the email and enters register (please no spam) @ (please no spam) nemetschek.defor the address. 

Save the registration file ... 
The program creates and saves the register.txt file before it opens the folder with the registration file in Windows Explorer. Now you can use all the options provided by Windows Explorer: for example, you can attach the file to an email, copy it to a computer with Internet access and so on. 

In addition, you can see the data that were written to the registration file.

	Click Finish. 

	Click Close to exit NemSLock License Manager.


You will receive a reply by email within a few minutes. This email provides information on the registration process and usually includes the registered license file.

Note: The registered license file is generated by an automated system. Consequently, any additional comments in incoming emails are not read. 


3. Installing the license file
Shortly after we received the registration request, we will send you the final license file to the email address you specified in the registration request.
Install this license file as follows:

	Save the license file to any folder on the hard disk.
If the license comes as a zip file, extract it.
	Next, install the license by double-clicking the license file ("customer#_seat.nslock").
Confirm the dialog box.
	As an alternative, you can also use License Manager to install the license file (Start -> (All) Programs -> Nemetschek -> Nemetschek SoftLock 2006 -> License Manager).
Click "Install - Install license" and then "Browse..." to select the license.
Click "Finish" to complete the installation process.
	Your registered license is displayed in the License Manager.  Clear the check box for the trial license (for example, seat 94 or 98). Make sure your registered license is the only license that is selected.
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