Support Forum

[Question] Fehlermeldung: Value for ValueInPalette(list) is not converted


Hallo zusammen,

bei mir ist heute zum ersten Mal die Fehlermeldung "Value for ValueInPalette(list) is not converted" (siehe Bild 1) aufgetreten. Muss ich bei dem Node "ShowInPalette" (gestern eingefügt) etwas verändern oder liegt das am Release?

Viele Grüße

Marco

Attachments (1)

img
2021-03-11_Releasenotes Allplan.JPG
Type: image/jpeg
Downloaded 13 times
Size: 17,72 KiB

Show most helpful answer Hide most helpful answer

Quote by f_hoeser
Hallo,
ich habe das gleiche Problem.

Im Anhang ist mein Skript. Die Fehlermeldung kommt, wenn ich das PythonPart mit einem Doppelklick bearbeiten möchte. Beim Starten des Skriptes aus dem Visual Scripting heraus, kommt keine Fehlermeldung.

Ich benutze Allplan 2021-1-6.

Danke für das Skript. Scheinbar gibt es hier ein Problem mit der automatischen Umwandelung vom Datentyp. Aber du kannst die Werte als Attribute an dies PythonPart zuweisen. Damit sparst du einige Zeit und einen Doppelklick, wenn du die Werte prüfen/sehen möchtest.

Wir werden das Problem von dem Node untersuchen...

1 - 8 (8)
  • 1

Hallo Marco,

ich habe alle "ShowInPalette" Nodes mal getestet und habe keine solche Problem. Könntest du daher uns das Skript zukommen lassen? oder mehr Information geben?

VG
Xinling

Hallo Xinling,

ich versuche, dir zunächst einmal mehr Informationen zu geben: Im Anhang habe ich dir dazu zunächst drei Bilder beigefügt. In meinem Skript soll die Querneigung (Überbau und Kragarm links und rechts) und die Längsneigung meiner Brücke als Information (grau hinterlegt in Bild 2) angezeigt werden. Ich habe deshalb den Node <ShowInPalette> verwendet. Bei <Value in Palette> steht die Bezeichnung (Text) drin, die für die Beschriftung herangezogen wird.

Ich hoffe, das hilft dir weiter.

Viele Grüße

Marco

Attachments (3)

img
2021-03-12_ShowInPalette1.JPG
Type: image/jpeg
Downloaded 24 times
Size: 25,87 KiB
img
2021-03-12_ShowInPalette2.JPG
Type: image/jpeg
Downloaded 25 times
Size: 42,82 KiB
img
2021-03-12_ShowInPalette3.JPG
Type: image/jpeg
Downloaded 20 times
Size: 17,96 KiB

Welche Version verwendest du? 2021-0-6?

Könntest du uns das Skript zusenden? Dann können wir das Problem analysieren. (meine Kontaktdaten solltest du schon haben.)

Hallo,

ich habe das gleiche Problem.
Im Anhang ist mein Skript. Die Fehlermeldung kommt, wenn ich das PythonPart mit einem Doppelklick bearbeiten möchte. Beim Starten des Skriptes aus dem Visual Scripting heraus, kommt keine Fehlermeldung.
Ich benutze Allplan 2021-1-6.

Attachments (1)

Type: application/zip
Downloaded 2 times
Size: 4,66 KiB

Quote by f_hoeser
Hallo,
ich habe das gleiche Problem.

Im Anhang ist mein Skript. Die Fehlermeldung kommt, wenn ich das PythonPart mit einem Doppelklick bearbeiten möchte. Beim Starten des Skriptes aus dem Visual Scripting heraus, kommt keine Fehlermeldung.

Ich benutze Allplan 2021-1-6.

Danke für das Skript. Scheinbar gibt es hier ein Problem mit der automatischen Umwandelung vom Datentyp. Aber du kannst die Werte als Attribute an dies PythonPart zuweisen. Damit sparst du einige Zeit und einen Doppelklick, wenn du die Werte prüfen/sehen möchtest.

Wir werden das Problem von dem Node untersuchen...

Quote by f_hoeser
Hallo,
ich habe das gleiche Problem.

Im Anhang ist mein Skript. Die Fehlermeldung kommt, wenn ich das PythonPart mit einem Doppelklick bearbeiten möchte. Beim Starten des Skriptes aus dem Visual Scripting heraus, kommt keine Fehlermeldung.

Ich benutze Allplan 2021-1-6.

Ich habe Dein Script ausprobiert. Folgendes ist mir aufgefallen:
1. Horizontale Linien produzieren eine "Division by Zero" error. Das könnte die Ursache für die FEhlermeldung sein, da
der Node in diesem Fehlerfall "none" zurückgibt. Und "none" kann nicht in einen Wert konvertiert werden
2. Die Performance beim Ziehen an einem Griff ist unterirdisch. Ich schaffe es nicht mal, einen Punkt zu fangen, so stark
wird die Mausbewegung verzögert. Ich vermute, es hängt mit dem Node ShowValuesInPalette zusammen.
3. Das Ziehen der Griffe aus der Schrägen in ein horizintale Lage funktioniert nicht (s. line_input.mp4)
Das wiederum schein ein Fehler in dem NodeLineInput zu sein.
4. Ich würde den NodeShowInPaletteLength dort einsetzen, wo Längen ausgegeben werden sollen.

Attachments (1)

Type: video/mp4
Downloaded 7 times
Size: 1,54 MiB

Danke für die Hinweise. Die Division by Zero muss ich in jedem Fall abfangen/umgehen. Ich werde das bei Gelegenheit ausprobieren und gebe Rückmeldung.

1 - 8 (8)
  • 1

https://connect.allplan.com/ uses cookies  -  More information

Accept