Support Forum

[Frage] Allplan PythonParts Issue Crash!


Hi there,

I lost yo much time convincing Allplan 2017 to connect to Visual Studio 2015 for remote debugging of Python-parts. Finally I realized after a lot of tries that I should use just Visual Studio 2015 and exactly ptvsd-3.0.0 - if I use ptvsd-2.2.0 or ptvsd-3.2.0 it does not connect. OK, although it connected it simply poped another error. But that is not all, after that Allplan crashed so much that I needed to deactivate license and activated it again for Allplan to work.
I realized that after that event I cannot run any Python-Part any more as as soon as I try it, Allplan crashes at once. This is really annoying, how can be software so unstable.

I recorded video where you can see that no PythonPart can be used any more:
https://www.dropbox.com/s/motd99cvouzehiw/Allplan-Crash.mp4?dl=0

Any idea how I can first recover Allplan to work again with PythonParts and second how to establish debug connection to work???

Thanks for any help, Primoz

11 - 14 (14)

I am sorry if my response was so direct, but the position of us engineers who are using the software is slightly different as for developers. The point is that we need to deliver projects normally on tight schedule and crashing like this then reinstalling from the scratch are the things which produces a lot of stress on us.
The point is that last time I was doing one house with parapet walls, I was so amazed that I could use FF components and I could be finished very quickly, but unfortunately this component worked just for one wall, for other walls from unknown reason didn't want to work and Allplan crashed by using them( each time when it crashed, it forgot license and I was required to return it back and activate it once more. Another example - I was doing reinforcement for one block where I had about 20 larger walls, and copying from library worked just for half of the walls, for the others I had faced problems and so on...

The point is that the software is unstable and for larger projects you could face serious problems as you do not know what you can expect and such conditions creates a lot of stress.

It is a pity that so good ideas in the software are somehow damaged, just because polishing of the software is not done...

Best Regards, Primoz

It's your point of view. As you said, you are engineer and not developer.
So, the best way is to contact Allplan support and expose your issue. If the problem can be reproduce, it will be fixed. If not, maybe the problem is known and cannot be fixed easily, or the problem is specific on your installation and perharps is the consequence of another problem.
As it seems that you have "tinkered" a lot, this may be related to this. If you need further explanation, maybe support can help, or training by Allplan trainers would be necessary and helpful.

Do you have development experience?
It is not always easy for a user to code a PythonPart or a SmartPart (and even when you have experience...). It is also important that the installation of Allplan is done correctly. Your previous remarks leave a doubt on this side.
This is why, it seems more appropriate, especially here on a user support forum, to remain factual and not to comment on the work done by the development teams, just as one should not comment on the questions asked.
I'm trying to see both sides...

If you cannot get what you want, the best thing is to restart from scratch: complete reinstall of Allplan and Visual Studio, with the required add-ins (and not copy and paste some files). If everything is correct, it will work, as it works on my computer and surely those of the development teams...
And then come back and ask for help if something's still wrong.


The point is that I am engineer and have as well software development experience, that is the reason the problem is solved. I have to live with instability which happens from time to time, that is the reason that I started to think to develop components for my own company so that I can use them when needed. I started testing smartparts but then turned to pytonparts as they control Allplan environment better. I am now just in phase of figuring out what is the best development environment and which tools to use.
For now I think I realized what is the problem, but I needed some time as till now I was not thinking to develop anything in Allplan, it just happened recently that I changed my mind…
Best Regards, Primoz

Problem solved, perfect!


11 - 14 (14)

https://connect.allplan.com/ verwendet Cookies  -  Mehr Informationen

Akzeptieren